29 29
balbes150

Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

Recommended Posts

2 hours ago, Reddwarf said:

You mat be right about that, but since these images also has dtb for OrnagePi I asked here.

Are you confused? My Amlogic images don't have any DTBS for Allwinner.

Share this post


Link to post
Share on other sites
44 minutes ago, balbes150 said:

Are you confused? My Amlogic images don't have any DTBS for Allwinner.

If you say so, I just saw that there was a dtb for orangepi and assumed it was for Allwinner. Are you saying that Armbian does not support Allwinner?

 

Share this post


Link to post
Share on other sites
26 minutes ago, Reddwarf said:

If you say so, I just saw that there was a dtb for orangepi and assumed it was for Allwinner. Are you saying that Armbian does not support Allwinner?

Armbian probably supports OrangPI\Allwinner and there are special images for this (I don't know exactly). But it's in other images. In this thread the info about the images for Amlogic. :)

Plis Specify where was the information about DTB for OrangPi ?

Share this post


Link to post
Share on other sites
4 minutes ago, balbes150 said:

Armbian probably supports OrangPI\Allwinner and there are special images for this (I don't know exactly). But it's in other images. In this thread the info about the images for Amlogic. :)

Plis Specify where was the information about DTB for OrangPi ?

I see, excuse my ignorance, I'm not familiar with the OrangePi's but consider buying one. I just saw a dtb for those in an earlier image, can't remember which or when.

Share this post


Link to post
Share on other sites

Hi,

 

I have Tronsmart s95 Vega pro 1GB box, I would like to use with armbian.  Armbian_5.71_Aml-s9xxx_Ubuntu_bionic_default_4.20.2_20190118.img.

I can not boot with tronsmart vega s95 pro dtb. I did not see choice for 1GB or 2GB dtb. How can I  taht set this is 1GB TV Box? 

Share this post


Link to post
Share on other sites
58 minutes ago, kenand said:

I have Tronsmart s95 Vega pro 1GB box, I would like to use with armbian.  Armbian_5.71_Aml-s9xxx_Ubuntu_bionic_default_4.20.2_20190118.img.

I can not boot with tronsmart vega s95 pro dtb. I did not see choice for 1GB or 2GB dtb. How can I  taht set this is 1GB TV Box? 

Use dtb p200 instead.

Share this post


Link to post
Share on other sites

I've added some usb sticks for extra storage to my boxes but rebooting them makes the boxes try to boot from them sometimes. Is it possible to edit the multiboot order to always boot from internal storage unless the av button is pressed? Not sure if thats possible but it would be cool to only boot from usb/sd when that button is pressed.

Share this post


Link to post
Share on other sites

I tested 20190118-NEXT-Ubuntu-Desktop some hours from card and installed it via armbian-config successfully onto eMMC now. Works as expected pretty good with USB-Sound(hence I got no speakers on Monitor to provide HDMI-sound) and Ethernet LAN on 2/16GB x96mini. The system is responsive and runs smooth. Also start-up seems faster compared to older builds.

@balbes150: After install I found the 20190122 images with kernel 4.20.2. What is new/changed in these builds?! As everything works pretty good on 5.0.0-rc2 for me, I'm not sure if I should downgrade kernel with newer version of image?!

Share this post


Link to post
Share on other sites
22 minutes ago, Turgus said:

I tested 20190118-NEXT-Ubuntu-Desktop some hours from card and installed it via armbian-config successfully onto eMMC now. Works as expected pretty good with USB-Sound(hence I got no speakers on Monitor to provide HDMI-sound) and Ethernet LAN on 2/16GB x96mini. The system is responsive and runs smooth. Also start-up seems faster compared to older builds.

@balbes150: After install I found the 20190122 images with kernel 4.20.2. What is new/changed in these builds?! As everything works pretty good on 5.0.0-rc2 for me, I'm not sure if I should downgrade kernel with newer version of image?!

If everything works at 5.0, there's no point in dropping to 4.20.

Share this post


Link to post
Share on other sites
4 hours ago, amirul said:

I see 20190122 now have separate s905 and s912 images. Is there a list of differences between the two?

Yes, from now on images for S905 and S912 will be released separately. So far, there are almost no differences between them. The only difference is the default DTB. Now in the images S912 specified a dtb to the VIM2 and you can try to run the image to S912. This is preparing to move to HW support. s905 and s912 use different variants of HW LIMA or PANFROST.

Share this post


Link to post
Share on other sites
1 hour ago, balbes150 said:

Yes, from now on images for S905 and S912 will be released separately. So far, there are almost no differences between them. The only difference is the default DTB. Now in the images S912 specified a dtb to the VIM2 and you can try to run the image to S912. This is preparing to move to HW support. s905 and s912 use different variants of HW LIMA or PANFROST.

Righto. s912 desktop running well so far on my T95Z Plus. Problem with usb fixed by using powered hdd docking. Great job :-)

Share this post


Link to post
Share on other sites

So I'v tested the 5.71 RC2 and RC3 images (desktop versions) on my 905 devices (MiniMxIII and MiniM8S).

The Ubuntu variant RC2 runs well on both devices, unfortunately there is no sound, no BT and no ethernet. WiFi works fine thou.

The Debian variant does not boot from SDCard since it claims it has no support for the cards voltage. It boots from an USB stick and behaves the same as Ubuntu.

 

The RC3 does not boot at all, just showing me the flashscreen. I have used the p200 dtb.

 

Edit: And yes, I have installed the new boot (aml-autoscript).

Share this post


Link to post
Share on other sites
18 hours ago, balbes150 said:

Yes, from now on images for S905 and S912 will be released separately. So far, there are almost no differences between them. The only difference is the default DTB. Now in the images S912 specified a dtb to the VIM2 and you can try to run the image to S912. This is preparing to move to HW support. s905 and s912 use different variants of HW LIMA or PANFROST.

 

This is a great news. When do you plan to integrate the panfrost driver? This is exactly what I am trying to achieve.

Share this post


Link to post
Share on other sites
12 hours ago, Reddwarf said:

The Ubuntu variant RC2 runs well on both devices, unfortunately there is no sound, no BT and no ethernet. WiFi works fine thou.

Try all variants of DTB p200 and p201

 

6 hours ago, Chaton Pascal said:

When do you plan to integrate the panfrost driver?

It's unknown.

Share this post


Link to post
Share on other sites

Great work balbes150, currently using 4.20.2 5.71 S912 and I work everything except the BT in a Qintaix Q912 3G, with an external BT solved. With the 5.0 kernel I did not activate the Swap and therefore not the Zram, I realized by modifying it to activate it for the 8 cores and upload the values to 75 = 1.5 g of ram.
I repeat great job balbes150.
PS: I found this regarding panfrost HERE

Share this post


Link to post
Share on other sites
3 hours ago, balbes150 said:

Try all variants of DTB p200 and p201

 

Ok, I'v done some more testing with the 905 devices and also with my MXQ Pro+ 4k (S905x):

 

Beelink MiniMxIII and Mini M8s:

Kernel 5 RC2 Ubuntu runs but without BT, sound and ethernet, WiFi works. Using dtb p200 or 201 makes no difference. Debian variant does not boot.

RC3 does not boot with dtb p200 and p201, however it does boot with OdroidC2 dtb, but now only ethernet works, no BT, no sound and no WiFi.

 

MXQ Pro+ 4k (905x) using p212 dtb:

Kernel 5 RC2 Ubuntu works same as for the 905 devices. Debian does not boot.

RC3 does boot, ethernet works, no BT, no sound and no WiFi.

 

Over all, kernel 5 images is very quick and responsive, video plays smooth and fine on all my devices. If I connect an external USB soundcard I get sound, have no BT dongle to test with at the moment.

 

Share this post


Link to post
Share on other sites
53 minutes ago, Reddwarf said:

MXQ Pro+ 4k (905x) using p212 dtb:

You need to check all the DTBS in the gxl group.

 

53 minutes ago, Reddwarf said:

RC3 does boot, ethernet works, no BT, no sound and no WiFi.

Are you correct ? If there is no system boot then nothing can work. :)

Share this post


Link to post
Share on other sites

..after a quick check on card I installed Armbian_5.71_Aml-s905_Ubuntu_bionic_next_5.0.0-rc3-desktop onto eMMC. Works like a charm so far on x96mini 2/16G.
If there will be a release with k 5 in 5.72 versions, I'll test it too..

Share this post


Link to post
Share on other sites

I can also confirm that a Beelink MiniMX (s905 1/8GB) is working well with 5.71 debian stretch 4.20.2. I just had to modify the uEnv.ini to set the gxbb-p200.dtb and even wifi works. I use the desktop version to test all features, but with only 1GB of ram, it seems better to use it as a server. The video test file plays well in windowed mode and it seems viewable in fullscreen but there are some frame dropped.

I'm not able to test sound since my lcd screen has no audio output and there is such output on that box.

Share this post


Link to post
Share on other sites
8 hours ago, balbes150 said:

 

I noticed that Armbian 5.72 showed up so I tested it on my MiniMxIII (s905) box:

 

The Debian image boots just fine (using dtb p200), WiFi works, no ethernet, no BT, no sound.

The Ubuntu image starts to boot but never finish due to it cannot initialize the SD card since it has no support for the cards voltage. It boots fine from an usb-stick, but same result as for the Debian image.

 

Edit: Using dtb p201 makes no difference.

Share this post


Link to post
Share on other sites

Incredibly slow eth0 connection: 6.5Mbps down and 14Mbps upload.
Cable and equipment work great for all other devices. How do I fix?

 

EDIT 1/25/19: if I have not copied over to eMMC yet, could this keep my download speed so low at 6.5Mbps? My other devices get 125+Mbps. 

 

Also: I attempted to backup to sdcard and at roughly 3GB copied, the desktop screen froze saying 16kb speed backup and it no longer updated the progress. So because I wasn't able to backup successfully, I decided not to transfer to eMMC yet. I will try booting up from a USB today to see if a backup becomes successful. I've been using a 32GB Samsung UHC1 class 10 card but maybe that's the issue idk.

 


s905x - installed "Armbian_5.71_Aml-s905_Ubuntu_bionic_default_4.20.2_desktop_20190122" with "...nexbox a95x.dtb"

 

armbianmonitor: http://ix.io/lzas

Edited by gameseg
armbianmonitor log, eMMC comments

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
29 29