8 8
balbes150

Armbian for TV box rk3328

Recommended Posts

35 minutes ago, armar said:

To get the wifi to work, do I need a different version of the img? Or can  it work with the image I have with the right dtb file? I remember there was WIFI versions of the img in the past.

And, can I just change the dtb file and reboot? Or do I have to get a fresh img and repeat step 2 ?

Wi-Fi to work you need three things: support in the kernel + DTB + firmware (possibly with extra parameters).

 

Share this post


Link to post
Share on other sites
1 hour ago, balbes150 said:

Wi-Fi to work you need three things: support in the kernel + DTB + firmware (possibly with extra parameters).

 

Does the img in your 1203 release

https://yadi.sk/d/DSO6euzB3ahemo/ARMBIAN/5.67/20181203/Armbian_5.67_Rk3328-tv_Ubuntu_bionic_default_4.4.143_desktop_20181203.img

have WIFI kernel support?

 

Or is the one in the 1117 WIFI directory more appropriate.

https://yadi.sk/d/DSO6euzB3ahemo/ARMBIAN/5.67/20181117/WiFi

 

On the MVR9 are you able to get WIFI to work on bionic ?

 

Or is it too ambitious to try to get Wifi working on a new box :)

 

thanks

Share this post


Link to post
Share on other sites

Now launched Armbian on MVR9 (rk3328), desktop resolution 1920x1080 (so-called 1080p mode). 720p video is normally played in the window. I tried to fill the entire screen - does not fly, but watchable. Launch the browser with YouTube (in normal mode, the video window on the right, a list is available) - all video works without brakes. If you expand to full screen, artifacts slip through. Switched the resolution of the desktop to 720-all video goes to full screen without brakes and artifacts, almost like in LE. Notice that I reworked the body to improve cooling (drilled pen drill for door handle hole above the CPU and did a side slot for the free passage of air (but without fan). If you bring your hand to the hole, I feel like there is warm air from the body.
For information-the system is running with SD card and wired Gigabit network.

By the way, he was surprised that YouTube in the browser at the resolution of the desktop 720 and in the YouTube indicated to use 720, when displayed in full screen (all video options, not only 720) is no problem. But if you switch to YouTube to use 1080 artifacts have already appeared ...

Share this post


Link to post
Share on other sites

The new version of the LE-9.1 aarch64 20181216 for rk3328. I can't get to Freaktab ("glitches" of my provider) yet, so please, to those who have the opportunity to publish the info about the release of new versions of Armbian and Libreelec for RK3328 and for RK3399 (Khadas Edge) on the public  FreakTab forum. :)

Share this post


Link to post
Share on other sites
3 hours ago, manuti said:

Any chance of running ARMBIAN in this box? ► https://www.cnx-software.com/2018/12/19/mx10-mini-cheap-android-9-tv-box/

It probably already works for the box you linked, but if I may suggest, this one already works for sure, it costs just a few dollars more (4/16 model), and has twice the amount of RAM. I wouldn't think twice:

 

www.aliexpress.com/item/A5X-Max-4GB-32GB-Smart-Android-7-1-TV-Box-KD-RK3328-Quad-Core-5G-WiFi/32841541783.html

Share this post


Link to post
Share on other sites

I tried out an old usb wifi dongle I had, and a really old BT dongle I had and both of them worked on my A5x Max box with

Armbian_5.67_Rk3328-tv_Ubuntu_bionic_default_4.4.143_desktop_20181203.img + rk3328-evb.dtb

They worked out of the box, no mods required.

 

The wifi dongle (from ebay)

Wifi For Raspberry Pi- 802.11n USB 150M Wireless RTL8188CUS

BT dongle

Trendnet TBW-101UB (really old version)

 

Another newer ASUS BT dongle did not work. If anyone knows of any newer BT dongles working let me know.

 

The other thing I noticed, is that if I plugin in a USB 3.0 thumb drive in the USB3.0 port, my wireless keyboard starts lagging/stopping. Has anyone seen this? Plugging the 3.0 drive in the USB 2.0 ports does not cause any problems.

 

I think GPU is still not working though.

Share this post


Link to post
Share on other sites
7 hours ago, amirul said:

Thanks. If I already have ver 20181203 and upgraded via apt, its the same yes?

You can take your time with the update, there will be a new kernel version soon.

Share this post


Link to post
Share on other sites

How do I install kernel headers in one of these OS images?

Quote

sudo apt-get install linux-headers-4.4.143-rk3328-tv
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-4.4.143-rk3328-tv
E: Couldn't find any package by glob 'linux-headers-4.4.143-rk3328-tv'
E: Couldn't find any package by regex 'linux-headers-4.4.143-rk3328-tv'

 

thanks

Share this post


Link to post
Share on other sites

Thank you @balbes150 and Armbian team for making it possible for these tv boxes and sbc. A little background, I've found Armbian when I search for a good os for my odroid c1, then it serves as file and dnla server since.  I also have a s905x box and I put LibreElec because I like how complete the os for that box; graphic, sound, wifi...

 

When the S905X2 box come out (Beelink GT1 mini), I thought it's an upgrade to what I already have and the CPU is similar, then I get it and later found out that it a completely new cpu and there're no linux for it yet. However, I think there will be support in the future.

 

I really want to have a nice Armbian box, I decided to get Beelink A1 (rk3328, GbE, USB3, 4GB ram, 32GB Rom) instead of rock64 for similar price. I like this beelink box because how small and come with complete set. Now I can run armbian and got to desktop when using rk3328-box.dtb but I have no ethernet, wifi and bluetooth. Other thing seems to work fine.

 

So can you guide me how can I get a correct dtb for my box? And my box has etl8821cu, can I compile it somewhere else and load it in armbian? I can edit dts and convert to dtb.

Share this post


Link to post
Share on other sites
17 hours ago, armar said:

How do I install kernel headers in one of these OS images?

For new kernel + headers

https://yadi.sk/d/apAYXzjHA2Pekw

 

8 hours ago, raksan said:

So can you guide me how can I get a correct dtb for my box?

 

8 hours ago, raksan said:

I can edit dts and convert to dtb. 

 

Try swapping the status values

 

status = "disabled"  to status = "okay"

status = "okay" to status = "disabled" 

 

in these sections.

 

ethernet@ff550000

 

ethernet@ff540000

 

Share this post


Link to post
Share on other sites
1 hour ago, balbes150 said:

I saw the current prices for RK3328 - they have declined significantly. Now I'm thinking about what model to buy ...  :)

Using an A5X Max, running quite well at the moment although I think I'll switch to the T95Z Plus I just received.

Share this post


Link to post
Share on other sites
4 hours ago, balbes150 said:

Try swapping the status values

 

status = "disabled"  to status = "okay"

status = "okay" to status = "disabled" 

 

in these sections.

ethernet@ff550000

ethernet@ff540000

 

I've tried that and it's still doesn't work. On some dtb, I get IP like 169.254.x.x I will play with it for a few day  to see it swapping other dtb work.

Share this post


Link to post
Share on other sites
43 minutes ago, raksan said:

I've tried that and it's still doesn't work. On some dtb, I get IP like 169.254.x.x I will play with it for a few day  to see it swapping other dtb work.

Try to pull the native dtb from Android firmware, convert it to DTS and compare with the available options to find the parameters that need to be changed.

Share this post


Link to post
Share on other sites
20 hours ago, amirul said:

Using an A5X Max, running quite well at the moment although I think I'll switch to the T95Z Plus I just received.

 

Can you tell me what are you using it for?  I plan on getting a 4gb box to run as a docker headless server for home use so I'd like to hear your experience

Share this post


Link to post
Share on other sites
20 minutes ago, blakadder said:

 

Can you tell me what are you using it for?  I plan on getting a 4gb box to run as a docker headless server for home use so I'd like to hear your experience

Currently using it as a general desktop, running quite well although I find the T95Z Plus runs better, so I am switching.

Share this post


Link to post
Share on other sites
On 12/28/2018 at 12:22 AM, balbes150 said:

Try to pull the native dtb from Android firmware, convert it to DTS and compare with the available options to find the parameters that need to be changed.

This is the entry of ethernet in my box. Somehow, the compartible gmac is rk322xh. I've change the rk3328-box @ff540000 to match my box, changed the clock and its references. If I keep rk322xh-gmac there's no error (dmesg | grep ether), and when I change to rk3328-gmac there's some error: stmmac_dvr_probe cannot get csr clock.

 

    eth@ff540000 {
        compatible = "rockchip,rk322xh-gmac";
        reg = <0x0 0xff540000 0x0 0x10000>;
        rockchip,grf = <0x3>;
        interrupts = <0x0 0x18 0x4>;
        interrupt-names = "macirq";
        clocks = <0x66 0xd1 0x4 0xd1 0x5 0xd1 0x7 0xd1 0x6 0x81 0x2 0x81 0x3 0x3a>;
        clock-names = "clk_mac", "mac_clk_rx", "mac_clk_tx", "clk_mac_ref", "clk_mac_refout", "aclk_mac", "pclk_mac", "clk_mac_pll";
        phy-mode = "rgmii";
        pinctrl-names = "default";
        pinctrl-0 = <0xd2>;
        status = "okay";
        reset-gpio = <0xcb 0x12 0x1>;
        clock_in_out = "input";
        tx_delay = <0x26>;
        rx_delay = <0x11>;
    };

Share this post


Link to post
Share on other sites

Hi,

Thanks Balbes, I am now able to boot my V88 mini III with your images (4.4 and 4.19). I summarize the procedure for those who have to burn uboot on the sd card:

After getting an image from Balbes repo, download also the files for uboot (ibdloader.img, trust.img, uboot.img) also available on his yandex repo:

  1. Burn Balbes image with Etcher or any other reliable software
  2. Burn uboot on sdcard as follows:
sudo dd if=path/to/idbloader.img of=/dev/sdb seek=64      conv=sync,fsync

sudo dd if=path/to/uboot.img     of=/dev/sdb seek=16384   conv=sync,fsync

sudo dd if=path/to/trust.img     of=/dev/sdb seek=24576   conv=sync,fsync

My box boots with rk3328-rock64.dtb but there is no ethernet and no wifi, but with rk3328-evb-100m.dtb I have eth0 working.

Share this post


Link to post
Share on other sites

Hi all,

 

Can someone please help me?  I am completely new to these Android tv boxes but I am fairly handy with Raspberry Pi's and installing Linux on X86 and so on, I am not a power user though!

 

I have a T9 Android box - 4gb RAM, RK3328 CPU, Mali 450 GPU.  I downloaded the Armbian images and burned them to an SD card with Etcher.  I have edited the "/extlinux/extlinux.conf" file as per instructions (I have tried all the files in the dtb folder, some start, others do nothing).  

 

When the device starts to boot, I always get a "I am getting error "ALERT! LABEL=ROOTFS does not exist. Dropping to a shell!" followed by a (initramfs) prompt.   I don't know enough about Linux to know what this means, other than it can't find a ROOT file system.  Reading the Freaktab forum posts I found a poster who was getting the same, and I followed the instructions on that forum, altering the extlinux.conf file but it doesn't work either.  I've tried various things but nothing works.  I tried the SD plus USB drive method and that did boot into Linux successfully but that's running on a USB drive and it's painfully slow and completely unusable.  I'm now completely out of ideas, can anyone help me get Linux running on this box?

 

Kind regards,

Ste

Share this post


Link to post
Share on other sites

I have the exact same box (T9 RT3328) and same problem as Quattrafoto an nytocs

On 1/4/2019 at 10:32 PM, Quattrofoto said:

When the device starts to boot, I always get a "I am getting error "ALERT! LABEL=ROOTFS does not exist. Dropping to a shell!" followed by a (initramfs) prompt. 

 

Any solution to this yet ?, ..or can anyone here point me in the right direction to cast some light on whats going on ?

 

Br

Thomas

Edited by abildgaardo
typos

Share this post


Link to post
Share on other sites
On 1/3/2019 at 5:13 AM, raksan said:

This is the entry of ethernet in my box. Somehow, the compartible gmac is rk322xh. I've change the rk3328-box @ff540000 to match my box, changed the clock and its references. If I keep rk322xh-gmac there's no error (dmesg | grep ether), and when I change to rk3328-gmac there's some error: stmmac_dvr_probe cannot get csr clock. 

Do not change the rk322xh.

Have you tried using the dtb (no changes) that you pulled from the firmware ?

 

On 1/5/2019 at 12:32 AM, Quattrofoto said:

I'm now completely out of ideas, can anyone help me get Linux running on this box? 

You need to collect your version of dtb with SD support.

 

 

Share this post


Link to post
Share on other sites
5 hours ago, balbes150 said:

Have you tried using the dtb (no changes) that you pulled from the firmware ?

Yes, I did but the box doesn't boot.  However, I've tried swapped  the ethernet entry of rk3328-evb.dtb and my box has ethernet now. However, with this dtb the box doesn't have usb 2 functionality, but I fixed it with changing the "otg" to "host". Now I have a full working box (minus wifi, bluetooth). And I also install armbian to emmc. Thank you very much for your work!

Share this post


Link to post
Share on other sites

I have a A5XMAX box running from SD card the

Armbian_5.67_Rk3328-tv_Ubuntu_bionic_default_4.4.154_desktop_20181227.img.xz

and I have been experimenting with the wireless-wlan section in  the rk3328-evb.dtb trying to get the builtin wifi to work.

The box has the rtl8723bs wifi chipset.

If I do a "sudo modprobe 8723bs" I see in dmesg

[  726.221116] =======================================================
[  726.221122] ==== Launching Wi-Fi driver! (Powered by Rockchip) ====
[  726.221126] =======================================================
[  726.221132] Realtek 8723BS SDIO WiFi driver (Powered by Rockchip,Ver v5.2.17.1_26955.20180307_COEX20180201-6f52) init.
[  726.221139] [WLAN_RFKILL]: rockchip_wifi_power: 1
[  726.221146] [WLAN_RFKILL]: wifi turn on power. -1
[  726.221153] mmc1:mmc host rescan start!
[  726.221158] RTW: module init start
[  726.221163] RTW: rtl8723bs v5.2.17.1_26955.20180307_COEX20180201-6f52
[  726.221168] RTW: build time: Dec 27 2018 14:15:10
[  726.221172] RTW: rtl8723bs BT-Coex version = COEX20180201-6f52
[  726.221405] RTW: module init ret=0

The wifi is not detected (in "ip a" or iwconfig). The wifi turn on power -1 does not look good. Any idea as to what is wrong? Does the problem look like it is in dtb or firmware settings or driver?

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
8 8