Single Armbian image for RK + AML + AW (aarch64 ARMv8)


75 75

Recommended Posts

The start system in Coreelec is not compatible with LibreELECE  Armbian  etc. If you run coreelec on your TV box, you will no longer be able to run LE and Armbian normally until the full recovery of the standard firmware via the USB Burn Tool and the new activation of the universal multi-boot, which is used in all new systems.


Questions that do not specify exact details (the exact image version, TV box model, detailed steps that were performed for DTB settings, and so on) will be ignored and deleted.


For all. I don't support s905x3. I don't have this equipment. All messages about this platform deleted. What works or doesn't work from this equipment - I don't know. I do not give any answers or comments on the s905x3 chip.


The build and publication of unified test images with a common core for the Rockchip Amlogic Allwinner platform begins.






Now you can download the latest versions of images and DEB packages from the official Armbian resource via the link.




Pay attention. Starting from version 20.08 (20200814), the configuration order for the used DTB changes.


Please note that the algorithm for initial configuration of the system for startup has changed. Instead of a file "uEnv.txt", the file "/extlinux/extlinux.conf " is now used. The rules for editing a file remain the same.

All Amlogic models now need the "u-boot.ext" file.

Before launching on Amlogic, you must copy or rename one of the existing files "u-boot-*" to "u-boot.ext".


For s905 (not X) - used u-boot-s905

For s905x and s912 - used u-boot-s905x-s912

For s905x2 and s922 - used u-boot-s905x2-s922


For g12a\g12b models, a single file is now used (files and u-boot.usb now replaces one u-boot-s922 file).

For the Allwinner platform, you no longer need to rename the scripts "boot.scr".

All "boot.scr" scripts have been canceled and are not used.




How to run these images on the Amlogic platform .

Now all images Armbian and LE has all the files for activate the multi-boot. Anything addition to download and copy to media is not required.


1. Download the image for your device
2. Unpack
3. Burn the image on the medium

4. Configure in the file (uEnv.txt) launch parameters for the desired platform and model (uncomment the desired lines and comment out or delete unused ones)


If universal multi-upload has not yet been activated on this device, you need to activate it once. There are several options for activating multi-loading.


option A

- Connect the prepared media to the device and turn on the power, boot into Android
- Open the app "Update&Backup"
- Click on "Select" local update and chose the file on the removable media
- Start "Update"
- System will reboot twice and start running the system from external media.


option B

-  try using the "toothpick method"



How to run these images on the Rockchip and Allwinner platform .

1. Download the image for your device
2. Unpack
3. Burn the image on the medium

4. Configure in the file (uEnv.txt) launch parameters for the desired platform and model (uncomment the desired lines and comment out or delete unused ones)
5. If your device does not support USB startup , you can only use SD cards and you need to add the correct u-boot to the SD card (for details on how to add it, see the text of this message)
6. Connect the prepared media to the device and turn on the power

Please note that the DTB configuration order has changed.

Now a single configuration method is used for all Rockchip Allwinner Amlogic platforms. The file (uEnv.txt) is used for configuration DTB all platforms. 

Now a single configuration method is used for all platforms, using the file (uEnv.txt). You need to edit this file to configure it. You need to uncomment the two lines that are responsible for your platform and specify the correct DTB for your model. If you use this image to run on the one platform, you can delete it from the settings file (uEnv.txt) strings from other platforms.


Need to pick up the option for the file system will run. Pay attention, after you add\change the dtb file, you need to try to run the system and waiting to run 7-10 minutes. If not happened, repeat with a different dtb file.


Pay attention.

The installation algorithm in eMMC has changed. My recommend that you perform a clean installation in eMMC. Be sure to make a full backup of eMMC before installing it in eMMC.

The system installation scripts in eMMC have changed accordingly. If you have a system with eMMC core 5 installed on RK33xx, it is advisable to perform a clean installation in eMMC to upgrade to the new version. 


For the aw H6 platform, all scripts are already in the image (which have the ending aw). You need to rename the files with the replacement (remove the ".aw" ending).


Fix for correct color to G12 (Amlogic S905X2 S922X)

For models based on g12 (s905x2 s922), which have a problem not the correct color , 

If you are starting the system from an SD card, you need to copy file to u-boot.ext,

If you are starting the system from an USB, you need to copy file  u-boot.usb to u-boot.ext

When installing in eMMC, you do not need to do anything with your hands, the installation script itself will perform the necessary system configuration and when running from eMMC, the system will work with the correct color.


Please note, this version for the transition to the release of a single image for the platform Rockchip + Amlogic + Allwinner. The new image after writing to external media and after configuring the used dtb (and if necessary adding the desired u-boot option to run from the SD card on the Rockchip and Allwinner) can be used simultaneously on AML (s9xxx), RK (rk3399 and rk3328) and AW (H6). If the TV boxes RK (rk3328 and rk3399) and AW (H6) in eMMC installed a new version of u-boot  with support for starting the system with USB, adding u-boot to SD card is not required, the system will automatically start on with USB.


Important change. With this version (>= 20200218), you can easily add the desired u-boot on any PC (including Windows) .


To do this, new versions of u-boot are downloaded on the site.


Rules for using the new u-boot option. Download, Armbian image, unpack. Write image Armbian to the SD card. Download and write the desired version of the u-boot file to SD card. Configure the DTB and the launch string (APPEND) in (uEnv.txt) for the desired model\platform.


Pay attention. Now you don't need to write u-boot with complex commands, you write the u-boot image with the same program as you usually write an Armbian image. This allows you to configure the system to run (including writing a u-boot image) on any PC (including Windows).


Pay attention. The new version changed the size of the partitions that are obtained when writing an image (all images have a fixed size of 5GB).  This u-boot entry option only applies to the new version 20200218 and subsequent versions. Don't try this for old images. This will not work on older images.


OLD add u-boot




In the "U-BOOT" directory on the site there are versions of files for writing to a universal image for these models, to run the system from an SD card on the AML, RK and AW platform. I pay attention, u-boot records need to be performed after writing the image to the SD card, with two commands (to save the existing partition table).



 Write u-boot to SD card. U-boot replacement is performed by two commands.

dd if=u-boot-<model>.img of=/dev/<SD_card> conv=fsync bs=1 count=442

dd if=u-boot-<model>.img of=/dev/<SD_card> conv=fsync bs=512 skip=1 seek=1


u-boot file for support model




For RK33xx

if you have windows and can't use the add u-boot commands to the SD card, use the SD+USB combination , write only the new u-boot to the SD card, and write the Armbian image to a USB storage device. And connect them together to the TV box.


To turn on the sound on models AML

where it is not present after the initial start. To enable audio , run the script (  You need to run the script






Odroid N2

When starting from an SD card on Odroid N2, you must, after recording the image, write uboot to the SD card, configure uEnv.txt, additionally rename the script ( in (boot.scr). To be able to start any system from any media (USB SD eMMC), i'm recommend using the updated version of u-boot-SPI. Details about u-boot-SPI for Odroid N2 can be found here.





Link to post
Share on other sites

Donate and support the project!

Armbian_5.99_Rk3399-tv_Debian_buster_next_5.4.0-rc7-next-20191115 and desktop images boot on a km8p (2/16gb) with several gxm dtb, but I think that gxm-q200.dtb the best one since only fast ethernet. As expected, wifi not recognized. For the desktop version, X11 does not launch properly and there is nothing in Xorg log file. I was able to launch manually startx as root and it worked a few minutes before freezing.

With the server image, I face kernel panics. I'll try another image with a more stable kernel to be sure the hardware is ok.

Link to post
Share on other sites

Tested with Nexbox A95X S905x 1GB (meson-gxl-s905x-nexbox-a95x.dtb) and Magicsee N5 S905x 2GB  (meson-gxl-s905x-p212.dtb) and Buster Desktop Image


Dev 20191118 on both Boxes boot OK


3D Acceleration OK (glxgears)


Wifi on A95X (RTL8189ETV) no Adapter etc. found

Wifi on N5 (QCA9377) is found but dmesg says "ath10k_sdio...Unsupported hardware version: 0x5020001"

BT on N5 not found


Next 20191119 on booth Boxes boot OK

HDMI Sound - No Sound

3D Accreleration OK


Wifi on A95X (RTL8189ETV) no Adapter etc. found

Wifi on N5 (QCA9377) is found but dmesg says "ath10k_sdio...Unsupported hardware version: 0x5020001"

BT on N5 not found

Link to post
Share on other sites

1 hour ago, balbes150 said:

Do you have a UART log ?

Same with meson-gxl-s805x-p241.dtb


I added the log from armbian 19.11.3 Kernel 5.3.11 too


Armbian_5.99_Aml-g12_Debian_buster_default_5.3.0_20191122 boots

Armbian_5.99_Aml-g12_Debian_buster_default_5.3.0_desktop_20191122 ended up with kernel panic


output_2019-11-23_09-22-34.log armbian19.11.3.log

Armbian_5.99_Aml-g12_Debian_buster_default_5.3.0_desktop_20191122.log Armbian_5.99_Aml-g12_Debian_buster_default_5.3.0_20191122

Link to post
Share on other sites

1. Your Board starts using u-boot-2019, which uses the "extlinux.conf" configuration file. For the UART console to work, you need to change the settings with


append: root=LABEL=ROOTFS rootflags=data=writeback rw console=uart8250,mmio32,0xff1a0000 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes net.ifnames=0




append: root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes net.ifnames=0


Then show the output of the UART.


2. You need to check the startup with all DTBS of the S905x group.

Link to post
Share on other sites

1 hour ago, nylonatathep said:

Okay that makes sense, i thought the log was very short^^


Here is the log, same error on other x905x dtb's.

hwacom and khadas dtb does not boot at all no log.

hope it helps

Alas, I have no such equipment and I can only speculate. If the console version starts normally, and the DE version gives an error, there may be a problem with the software. For a quick test of the source of the problem-you can remove the entire directory with kernel modules (/lib/modules) from the media. If the error persists, try replacing the kernel and modules by taking them from the production system.

Link to post
Share on other sites

Okay, succsess! The images are okay for LaFrite.

Was my fault :(

There was an error message that only appeared on screen not on UART messages. That message says that one module file cannot be loaded (bad ELF header)...

After some investigaton I testet my USB drive's an both of them have some bad sectors and these are not affected when I flash a minimal image.

I think they are corrupted between the many new flashes by testing the images.

When I use an new USB drive erverything is booting correctly with 5.3 and 5.4 Images but with 5.4 there is no Audio.

Thanks for your work and the help with the console output etc.


Link to post
Share on other sites

The AML-g12-legacy images are universal. They can be run on the RK platform.  :)


If the eMMC has a u-boot version that supports direct USB startup, it is sufficient to configure the file (extlinux.conf) and the system can run on RK. If the eMMC does not support USB startup, you can use the combined method. Write to SD card micro image u-boot for the desired model of the RK chip. Write an Armbian image to a USB drive, configure (extlinux.conf), connect both media to the device and turn on the power. The system will automatically start from the USB drive.


The images themselves are in directories with a new label (current version 19.11.3) at this link.


U-boot micro-images available for use.



A list of available images can be found in this post.




Link to post
Share on other sites

Added new images CURRENT 19.11.3 (20191126) with 5.3 universal core. These images are now available on the MEGA website.


All previous images are moved to the OLD directory.
For the starter kit, I expanded the list of available images.





Link to post
Share on other sites



I'm trying to get the sound out of SPDIF on AMLG12 without success.

First, maybe there is an error in the script. If I remove the redirection to /dev/null, I've got the next error:

amixer: Unable to find simple control 'SPDIFOUT Playback',0


$ amixer | grep SPDIF
Simple mixer control 'SPDIFOUT',0
Simple mixer control 'SPDIFOUT Playback Channels Mix',0
Simple mixer control 'SPDIFOUT Playback Gain Enable',0
Simple mixer control 'SPDIFOUT SRC SEL',0
Simple mixer control 'SPDIFOUT_B',0
Simple mixer control 'SPDIFOUT_B Playback Channels Mix',0
Simple mixer control 'SPDIFOUT_B Playback Gain Enable',0
Simple mixer control 'SPDIFOUT_B SRC SEL',0
Simple mixer control 'TOHDMITX SPDIF SRC',0


Is anyone able to get sound out of SPDIF/TOSLINK?


"speaker-test -c2" execute without error, but without sound to.


Link to post
Share on other sites

X hangs on Armbian_19.11.3_Aml-g12_buster_current_5.4.0_desktop_20191130.img.xz


cat /var/log/Xorg.0.log|grep EE
[    20.595] Current Operating System: Linux DEALDIG-BOXD6 5.4.0-aml-g12 #19.11.3 SMP PREEMPT Sat Nov 30 14:48:45 MSK 2019 aarch64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    22.532] (EE) modeset(0): glamor initialization failed


System:    Host: DEALDIG-BOXD6 Kernel: 5.4.0-aml-g12 aarch64 bits: 64 compiler: gcc v: 7.4.1 Console: tty 1
           Distro: Armbian GNU/Linux 10 (buster)
Machine:   Type: ARM Device System: Amlogic Meson GXM (S912) Q201 Development Board details: N/A
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Touch Keyboard K400 Plus charge: N/A status: N/A
CPU:       Topology: 8-Core (2-Die) model: N/A variant: cortex-a53 bits: 64 type: MCP MCM arch: ARMv8 rev: 4
           features: Use -f option to see features bogomips: 0
           Speed: 1512 MHz min/max: 100/1512:1000 MHz Core speeds (MHz): 1: 1512 2: 1512 3: 1512 4: 1512 5: 1000 6: 1000
           7: 1000 8: 1000
Graphics:  Device-1: meson-gxm-dw-hdmi driver: meson_dw_hdmi v: N/A bus ID: N/A
           Device-2: meson-gxm-mali driver: panfrost v: kernel bus ID: N/A
           Display: server: 1.20.4 driver: fbdev,modesetting tty: 164x33
           Message: Advanced graphics data unavailable in console for root.
Audio:     Device-1: meson-gxm-dw-hdmi driver: meson_dw_hdmi bus ID: N/A
           Sound Server: ALSA v: k5.4.0-aml-g12
Network:   Device-1: meson-gxbb-dwmac driver: meson8b_dwmac v: N/A port: N/A bus ID: N/A
           IF: eth0 state: down mac: 98:13:39:bd:48:17
           Device-2: pwm-clock driver: pwm_clock v: N/A port: N/A bus ID: N/A
           Device-3: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a bus ID: 1-2:3
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: 00:0e:c6:f9:e7:6d
           IF-ID-1: wlan0 state: up mac: 10:d0:7a:bb:b9:ab

Link to post
Share on other sites

Good news. Managed to find a way to work around the color issue on G12 platform + kernel =>5.4  with corrupted AML u-boot. You need to download and copy all the files from this directory to the media. New versions 20191208 already have some of the necessary files, you only need to add one  file u-boot.ext


Additional file download and copying (u-boot.ext) only need if your device screen color is not correct.

Link to post
Share on other sites

I noticed that the Build_Armbian git tree had a new set of changes merged in a couple of days ago.  I tried it out last night and there is one issue that I have seen so far.  I did a build of 'Armbian_19.11.3_Aml-g12_bionic_current_5.4.0.img and the debs and img are missing the dtb files.  I will copy the dtb's from another build to further test, but wanted to let you know of this issue.  I noticed a lot of code restructuring in this set of build changes, and since it hasn't been announced yet, I suspect I am trying things before they are ready.


Link to post
Share on other sites

New image DEV 20191209 kernel 5.4.1


Pay attention. This version changes the setting of the DTB for the Odroid models N2. Now all tuning principles are common to all models (files uEnv.ini and extlinux.conf). For models based on g12 (s905x2 s922), if you do not have the right color, you need to use the dual boot mode. To do this, use the SD card and add the "u-boot.ext" file to the Sd card. You can download this file from the site or rename an existing in  image to u-boot.ext.

Link to post
Share on other sites

This topic is now closed to further replies.

75 75