Jump to content

Disable yandex mirror for requests from Ukraine

Recommended Posts

16 hours ago, AZ8 said:

Requests to yandex blocked by most providers in Ukraine.


OMG :( We have one mirror in Ukraine. Is that blocked in Russia?


16 hours ago, AZ8 said:

when roundrobin returns yandex as a mirror

Here is the code. I have asked author to check what would best to deal with such exceptions that we resolve this problem at server side and users don't need to tackle this. Adding some sort of "international-relations.db " ?

Link to comment
Share on other sites

23.09.2022 в 17:10, TheLinuxBug сказал:

Hopefully that solves this issue for now.

No! The problem is on the side of the provider of another country!

And it should be solved in a different way.

There are no problems with the Yandex service.

Link to comment
Share on other sites

23.09.2022 в 11:06, Igor сказал:

We have one mirror in Ukraine. Is that blocked in Russia?

No! These are some popular services in Russia that are blocked in some other countries for users who try to reach them.
Conversely, I have no problems getting through to anywhere in the world.

Link to comment
Share on other sites

apt service was disabled temporally until some solution is implemented in re-director service. This way people, which might be blocked, doesn't have troubles, while main download remain unchanged - manual selection of another mirror. IMO this is good solution for now.


Link to comment
Share on other sites

Hi, I am facing the same issue. I am from Ukraine and our government blocked russian services for reasonable reason.
I've read, that one of the sources redirecting me to this blocked mirror and I couldn't do anything with it on my side. Is it true?
How can I fix it?


user@rockpi-4b:~$ sudo apt update && apt install -yq --no-install-recommends gcc         libgirepository1.0-dev         python3.6 python3-setuptools python3-pip python3-openssl python3.6-dev         python-gi python-gobject-2 python-gi-cairo python3-gi python3-gi-cairo         gir1.2-gtk-3.0 gir1.2-nm-1.0         librsvg2-dev libglib2.0-dev         openssh-server         net-tools         musl-dev         ttf-dejavu         adwaita-icon-theme         dbus-x11         x11-xserver-utils xinit xserver-xorg xserver-xorg-legacy xserver-xorg-input-libinput         xserver-xorg-video-fbdev xterm         libgtk-3-dev libgtk2.0-0 libgles2-mesa-dev libnss3 libxss1 libxtst6 libgconf-2-4 xfonts-base qemu-user-static         network-manager-gnome         alsa-utils         pulseaudio         xvfb         chromium-browser         xdotool         v4l-utils         portaudio19-dev         python3.6-distutils         cmake         xdg-utils         netcat
Hit:1 http://ports.ubuntu.com jammy InRelease
Hit:2 http://ports.ubuntu.com jammy-security InRelease                                                      
Hit:3 https://ppa.launchpadcontent.net/deadsnakes/ppa/ubuntu jammy InRelease                                
Hit:4 http://ports.ubuntu.com jammy-updates InRelease                            
Hit:5 http://ports.ubuntu.com jammy-backports InRelease
Get:6 http://mirror.yandex.ru/mirrors/armbian/apt jammy InRelease [2,294 B]
Err:6 http://mirror.yandex.ru/mirrors/armbian/apt jammy InRelease
  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Reading package lists... Done        
E: Failed to fetch http://apt.armbian.com/dists/jammy/InRelease  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: The repository 'http://apt.armbian.com jammy InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


Edited by Roman Khudobei
hiding sensitive info; providing more information; improve explanation;
Link to comment
Share on other sites

I was able to fix the issue with the help of this topic, in case anyone searching

I am also experiencing problems surfing Armbian website here. I tried to look for Rock Pi 4 B images and also for the archive. It also redirected me to "mirror.yandex.ru". Today I could access these pages, because I was redirected to  another source.

Edited by Roman Khudobei
Link to comment
Share on other sites

my "5 cents"...

correct way, as it was noticed already, to choose region in apt sources file, like in this forum post

and corresponding docs page




And about armbian-config... For now, 08 feb 2024, image Armbian_23.11.1_Uefi-x86_bookworm_current_6.1.63_xfce_desktop.img
armbian-config in my case shows only one line in mirrors selection list: "0 - Automated"
This is because for now url http://apt.armbian.com/regions is defunct, and, consequently, in armbian-config code in file /usr/lib/armbian-config/jobs.sh
 part of code for acquiring mirrors can be (temporarily) corrected like this:


                # Default automated mirror
                LIST=( "0" "Automated" )
                mirrors=( "${url}" )

                ## Mirrors for each region
                #for region in $(wget -qO- "${url}/regions" | jq -r '.[]' | sort | grep -v default); do
                #       LIST+=( "${#mirrors[@]}" "Region ${region}" )
                #       mirrors+=( "${url}/region/${region}/" )

                # Individual mirrors
                for mirror in $(wget -qO- "${url}/mirrors" | jq -r '.[] | .[]' | sort | uniq); do
                        LIST+=( "${#mirrors[@]}" "${mirror}" )
                        mirrors+=( "${mirror}" )

this way mirrors extracted from http://apt.armbian.com/mirrors and displayed correctly.

Edited by hex_messer
Link to comment
Share on other sites

oh, I figured out, how it should be coded to select regions :


               # Mirrors for each region
               for region in $(wget -qO- "${url}/mirrors" | jq -r 'keys' | jq -r '.[]' | sort | grep -v default); do
                       LIST+=( "${#mirrors[@]}" "Region ${region}" )
                       mirrors+=( "${url}/region/${region}/" )


And now it looks like this in armbian-config:

 Configuration utility, Armbian 23.11.1 stable,
         ┌──────────────────── Select APT mirror ──────────────────────┐
         │ Select mirror                                               │  
         │ ┌─────────────────────────────────────────────────────────┐ │  
         │ │   0   Automated                                         │ │  
         │ │   1   Region AS                                         │ │  
         │ │   2   Region EU                                         │ │  
         │ │   3   Region NA                                         │ │  
         │ │   4   Region OC                                         │ │  
         │ │   5   http://armbian.chi.auroradev.org/apt/             │ │  
         │ │   6   http://armbian.hosthatch.com/apt/                 │ │  
         │ │   7   http://armbian.lv.auroradev.org/apt/              │ │  
         │ │   8   http://armbian.systemonachip.net/apt/             │ │  
         │ │   9   http://armbian.tnahosting.net/apt/                │ │  
         │ │   10  http://au.sbcmirror.org/armbian/apt/              │ │  
         │ │   11  http://fastmirror.pp.ua/armbian/                  │ │  
         │ └────↓(+)─────────────────────────────────────────30%─────┘ │  
         │                 <  OK  >         <Cancel>                   │  


I hope, this should be posted somewhere to be corrected in mainstream code, how and where to do it?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines