65 65
balbes150

ARMBIAN for Amlogic S905 and S905X (ver 5.44 =<)

Recommended Posts

@balbes150

Awsome. Up time 2hours 

Sys load 2.03.  Temp got to 78 then backed down to 76 now steady 76

No crash no freeze yet no modification for cooling except for making opening for airflow

IMG=jessie xfc latest from test folder

Share this post


Link to post
Share on other sites

Image update 20170302. Now, all the images should work the procedure for installing to the internal memory. To use setup, you must consider a number of nuances. 1. Before installation we strongly recommend to do a full backup of the internal memory (e.g. team dd_backup_x) and move the copy to another storage medium (e.g. on a PC). 2. Be sure to check all devices (wifi, sound etc etch). 3. If all the required works when run from external media, you can start the installation. To start the terminal. To switch to the superuser "root" to execute the command "su -" (su "space", "minus"). Run as root the command "./install.sh" . The procedure is not fast, as there is a complete copy of the operating system from external media in memory (eMMC). Notice for owners of TV boxes with 8 GB of eMMC. When you install the desktop versions (MATE and XFCE) TO START the installation, optimize system. To reduce the amount of programs installed for example to uninstall office packages. What would be the size occupied by the system on external drive was less of the size of the internal memory (partition /dev/data). By default , desktop take more seats than the existing partition in the internal memory (/dev/data). Therefore, the system will fail to start.

Share this post


Link to post
Share on other sites

@balbes150

this is a mightyfine piece of work here :-) really seems like you've gotten the bugs out. so im on  debian desktop 20170228. typeing from the a95x now i've got system up time over 3 hours and my cpu temp is steady at 57c  this image seems to work very well and ive allready updated and installed other packages etc.

     so , QUESTION =  since im not overly concerned with the emmc install is there a big difference between  20170228 and the 20170302 images ?

 

also i'm wanting very much to learn how this is built as I want to try to port Kali and parrotsecurity os to this platform. Can you give me any pointers tips or tricks ? is there a  a general tutorial/guide for this type of thing ? can you tell me what the major differences between the a95x-s0905x and Odroid c2 platforms are ? i found a pre rolled img for Odroid c2 that id like to port to the nexbox would they be close to compatable?

 

thanks very much for your time and effort in this project , you've given my silly android box new purpose,

and given me inspiration.

 

Cheers

Astr4y4l

Share this post


Link to post
Share on other sites

@Tieu Vinh Long

hi , i've done some modification for cooling but can't decide between liquid coolant or air-injection ,

i've some ideas  to discuss is there a way to private message me so as not to clutter the forum with off-topic posts?

and do you have a place to upload pictures of the modifications i'm makeing?

Share this post


Link to post
Share on other sites

New image (dir Test 20170303) correction module mali. Checked on S905X - everything works, the temperature is over 70 degrees, the system is not falling. Please check at home. Please check the work WiFi network.

Share this post


Link to post
Share on other sites

wow, yandisk still not working?

did anyone mirror the builds?

i want to get the new one from dir/TEST

debian with desktop.any help plz?

Share this post


Link to post
Share on other sites

Hello!

I installed Armbian_5.26_S9xxx_Ubuntu_xenial_3.14.29_server_20170303.img to a generic S905x tv box that calls itself a 'QcoCe Z11' and it almost works perfectly.

 

My main issue is I am only getting audio from the HDMI out, not from the analog outputs I am using for speakers around the house. This is what I get from aplay -l and -L

**** List of PLAYBACK Hardware Devices ****
card 0: AMLM8AUDIO [AML-M8AUDIO], device 0: I2S.39 T9015-audio-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 1: SPDIF.40 dit-hifi-1 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 2: PCM.41 pcm2bt-pcm-2 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
sysdefault:CARD=AMLM8AUDIO
    AML-M8AUDIO,
    Default Audio Device
dmix:CARD=AMLM8AUDIO,DEV=0
    AML-M8AUDIO,
    Direct sample mixing device
dmix:CARD=AMLM8AUDIO,DEV=1
    AML-M8AUDIO,
    Direct sample mixing device
dmix:CARD=AMLM8AUDIO,DEV=2
    AML-M8AUDIO,
    Direct sample mixing device
dsnoop:CARD=AMLM8AUDIO,DEV=0
    AML-M8AUDIO,
    Direct sample snooping device
dsnoop:CARD=AMLM8AUDIO,DEV=1
    AML-M8AUDIO,
    Direct sample snooping device
dsnoop:CARD=AMLM8AUDIO,DEV=2
    AML-M8AUDIO,
    Direct sample snooping device
hw:CARD=AMLM8AUDIO,DEV=0
    AML-M8AUDIO,
    Direct hardware device without any conversions
hw:CARD=AMLM8AUDIO,DEV=1
    AML-M8AUDIO,
    Direct hardware device without any conversions
hw:CARD=AMLM8AUDIO,DEV=2
    AML-M8AUDIO,
    Direct hardware device without any conversions
plughw:CARD=AMLM8AUDIO,DEV=0
    AML-M8AUDIO,
    Hardware device with all software conversions
plughw:CARD=AMLM8AUDIO,DEV=1
    AML-M8AUDIO,
    Hardware device with all software conversions
plughw:CARD=AMLM8AUDIO,DEV=2
    AML-M8AUDIO,
    Hardware device with all software conversions

 

But if I run alsamixer I only have one volme control, for DAC Digital, the other outputs (audio spdif, audio i2s, ext spk) all will only allow me to mute/unmute.

 

Does anyone know how to enable analog audio out?

Thanks

Share this post


Link to post
Share on other sites

did someone got the osmc from the vero 4k running on a different device or the kodi packages from there at least, since it seems to be based on armbian as well?

Share this post


Link to post
Share on other sites

@xXx

 

I have a suggestion. Make the script dd_backup_x change, what would the script check in the root of the media directory /ddbr (if not created) and put the backup in that directory. This is to ensure that when you installed to the internal memory, this directory is NOT copied to eMMC.

Share this post


Link to post
Share on other sites

Well ..

latest debian xfce. And is working. The media player hung immediately.  Had to pull power plug to shutdown.  Apt-get remove --purge mpv.

Apt-get install vlc.. about to see if that works for me.. hope for success ...

 

Share this post


Link to post
Share on other sites
On 5/3/2017 at 4:54 PM, balbes150 said:

I have a suggestion. Make the script dd_backup_x change, what would the script check in the root of the media directory /ddbr (if not created) and put the backup in that directory. This is to ensure that when you installed to the internal memory, this directory is NOT copied to eMMC.

Sure, i can do that.

I'm a bit short of time these days, but at some point (hopefully soon) i'll post a new script with all the changes.

Share this post


Link to post
Share on other sites
17 hours ago, mmss said:

Hi, with debian on s905x hardware acceleration is working?

I haven't checked.

 

52 minutes ago, xXx said:

Sure, i can do that.

I'm a bit short of time these days, but at some point (hopefully soon) i'll post a new script with all the changes.

Then one other suggestion, add the option to create a copy of the first 3.5 GB of internal memory (not total memory). Most firmware in its original state beyond these limits. Therefore, to restore enough to make a copy of the first 3.5 GB.

 

Share this post


Link to post
Share on other sites
7 hours ago, balbes150 said:

I haven't checked.

 

Ah ok, I asked why test.mp4 and test1.mp4 videos are jerky...

Share this post


Link to post
Share on other sites

The new backup/restore script is ready and tested.

Not a new script really, just some usefull additions.

Some proof here

You can download it from here

All the changes are in the script's comments as usual.

Hope it helps.

Share this post


Link to post
Share on other sites
17 hours ago, xXx said:

The new backup/restore script is ready and tested.

 

Found a small bug in the script when checking free space. If free space is less than the total size of the internal memory, the work stops. But this is not correct, to create the compressed copy can be quite much less space. While disabled interrupt the script in this parameter, there is only a warning.

 

 

Share this post


Link to post
Share on other sites
3 hours ago, balbes150 said:

If free space is less than the total size of the internal memory, the work stops. But this is not correct, to create the compressed copy can be quite much less space. While disabled interrupt the script in this parameter, there is only a warning.

If the script allow the user with less space to continue, and then the user choose uncompessed backup by mistake, the system will hang.

I could update the script to allow only compressed backup if the free is less than EMMC size, but again... you cannot predict the compessed

size of the final backup ( depends of the compressibility of user's files ) and a hang can happen again.

So i decided to leave it as is, for safety.
If someone has to take a backup, it is better to use a USB/SDCARD that have space.

Share this post


Link to post
Share on other sites
On 8. 3. 2017. at 3:51 PM, mmss said:

 

Ah ok, I asked why test.mp4 and test1.mp4 videos are jerky...

By me, too...

Look like 16 pictures pro second, no 24...

And have not full hd, only 720p.

You tube ok, kodi not.

Temperature 70dg/c, ok, florence virtual keyboard, dont work, on tronsmart airmouse I have not - , and vithout - , have not " apt-get"...

And this is a great problem for me.

I am not a very expirienced linux user 

Any help, link, anything?

Tnx.

Share this post


Link to post
Share on other sites
On 10.03.2017 at 10:01 PM, Tommy21 said:

Is there a place to see changelog from your armbian images?

There are no big changes, only bug fixes.

 

On 08.03.2017 at 5:51 PM, mmss said:

Ah ok, I asked why test.mp4 and test1.mp4 videos are jerky...

In Debian or Ubuntu ?

 

19 hours ago, etona said:

By me, too...

Look like 16 pictures pro second, no 24...

And have not full hd, only 720p.

You tube ok, kodi not.

Temperature 70dg/c, ok, florence virtual keyboard, dont work, on tronsmart airmouse I have not - , and vithout - , have not " apt-get"...

And this is a great problem for me.

I am not a very expirienced linux user 

Any help, link, anything?

Tnx.

These images are NOT intended for full video playback. For this is LE. Is a desktop or server system to replace conventional PCs.

What do You mean under the expression "no apt-get". The system has Synaptic for graphical package installation. apt-get also works.

Share this post


Link to post
Share on other sites
1 hour ago, balbes150 said:
On 8/3/2017 at 3:51 PM, mmss said:

Ah ok, I asked why test.mp4 and test1.mp4 videos are jerky...

In Debian or Ubuntu ?

With both ?

Share this post


Link to post
Share on other sites

@balbes150

Sorry to annoy you again, but i have a little question for you:

Do i need to have the original android firmware in my MiniM8S box for the installation to EMMC to be successful?

I tried 7 times yesterday with your latest ubuntu mate image, and although everything went well ( no errors ) the system

was not able to boot after installation. I finally manage to brick my system, and the pin sorting method was mandatory

( again :D ) in order to bring it back to life. I must tell you that every time i tried installation to EMMC, i had LibreELEC on it.

And yes, i removed many packages before attempting the installation, to a point where the used space is only 2.6G

I'm trying to run the OS from EMMC, in order to improve dd_backup_x script in every situation ;).

@everyone

Has anyone managed to successfuly install ubuntu mate to internal EMMC in MiniM8S (not II) ???

If yes, how?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
65 65