9 9
NicoD

NanoPi M4 V2 - M4 Image not working

Recommended Posts

@pask i try the last minimal binary image from piter75.

 

i take another SD Card but nothing happens

no green LED ,only the Red, no signal on HDMI , nothing on LAN.

 

I create the card in the console:

sudo dd if=Armbian_5.99_Nanopim4v2_Debian_buster_default_4.4.192_minimal.img of=/dev/sdb bs=1M

 

what is the problem. should i take out the NVME Modul. or is my Pi broken....i got two. One is in Alu Case number Two is still naked. but no one works

 

Please Help i need it for the new house from my parents

 


 

Share this post


Link to post
Share on other sites

Error Detected........Power adapter....i used my Pixel Power adapter....but the nanopi m4 not support PD/QC Power Adapter.

 

Now its runnig:beer:

Share this post


Link to post
Share on other sites
17 minutes ago, Enrico said:

no green LED ,only the Red, no signal on HDMI , nothing on LAN

Hmm... is it only mine unit that works well with legacy kernel image and latest u-boot?

 

If you want you can try latest `current` image with 5.4.0 kernel: https://drive.google.com/open?id=1R26QdAaoNJDDmvNvKNUZWT53OZsJnVkj

 xz -dcv Armbian_19.11.3_Nanopim4v2_buster_current_5.4.0_minimal.img.xz | sudo dd bs=1M of=/dev/sdb

You can use above command line to skip explicit decompression step.

 

EDIT: Ok. I just saw your latest message.

Share this post


Link to post
Share on other sites

I rebased my branch onto latest master changes.

Took me some time to make the sound working in kernel 5.4.

 

Branch is now named nanopi-m4v2-bring-up and supports "legacy", "current" and "dev" targets.

Did not test "legacy" much yet but "current" 5.4 works quite well.

In dev wi-fi is broken, but anyway "current" is much more compelling as it is 5.4 vs. 5.4-rc1 in dev.

 

Command line for "current":

./compile.sh BOARD=nanopim4v2 BRANCH=current RELEASE=buster BUILD_MINIMAL=yes BUILD_DESKTOP=no KERNEL_ONLY=no KERNEL_CONFIGURE=no

 

Share this post


Link to post
Share on other sites
On 11/28/2019 at 11:40 PM, piter75 said:

Took me some time to make the sound working in kernel 5.4.

 

Branch is now named nanopi-m4v2-bring-up and supports "legacy", "current" and "dev" targets.

 

Great job, @piter75!

 

"current" buster desktop works well for me. The debug ttl console too.

Performance are much better than default friendlyelec 4.4.y kernel's ones, although not overall better than those of the ddr3 version 1 nanopi m4 (see https://www.cnx-software.com/2019/10/28/nanopi-m4v2-kit-review-part-2-friendlycore-desktop/):

Memory performance (big.LITTLE cores measured individually):
memcpy: 1880.5 MB/s (0.6%)
memset: 8430.7 MB/s (0.6%)
memcpy: 3729.4 MB/s
memset: 8492.3 MB/s (1.0%)

Complete sbc-bech results here: http://ix.io/23eC

 

Both sd card read and write speeds are good: 70MB/s with a sandisk 32GB extreme pro card

 

Stability also looks good, but requires more time to be tested.

As soon I'll be able to run some panfrost benchmarks, I'll update. By the way, desktop experience is smooth and stable and sound works too, but lack of acceleration is limiting when watching videos, although the 5.4 kernel improved speed over the 4.4.y is evident.

 

The only "small" issue I have found so far, is that boot is a bit slow. And for about 30 seconds I do not see any activity, neither on the serial console, nor on hdmi. Perhaps because of  "printk: bootconsole [uart8250] disabled" ?

 

I'm going to do some usb storage tests, before considering this board ready for replacing the raspberry pi4 I use at the moment as my home nextcloud server.

Share this post


Link to post
Share on other sites

@piter75 I am trying to get rt5651 sound on nanopc t4 kernel 5.4. But only static noise in headphone now. If you have rt5651 sound on m4, would you please publish you kernel config and patch(if any)?

 

And the bluetooth is broken on 5.4, while it worked on 5.2. Does your bluetooth work well on 5.4?

Share this post


Link to post
Share on other sites

@piter75Thanks.

Is the CONFIG_SND_SOC_ROCKCHIP_RT5651only select the codec and i2s, without additional source files like rockchip_5640.c?

Share this post


Link to post
Share on other sites

Even confusing the bluetooth came to work unexpectedly after I adjusted i2c1 parameters in dtb in order to get sound from rt5651 and reboot. While cannot get sound playback from codec still. There seems a ghost in my nanopc t4.:rolleyes:

Share this post


Link to post
Share on other sites

@Hover did you change the sound-dai to point to i2s0 in the following line?

https://github.com/armbian/build/blob/80b757ac27f58085f8c36302a4cd45ab3caa7ae4/patch/kernel/rockchip64-current/board-nanopi-m4v2-dts-add-sound-card.patch#L22

 

T4's codec is connected to a different i2s bus than M4*

 

You will have to enable i2s0 similar to what I did for i2s1 here: https://github.com/armbian/build/blob/80b757ac27f58085f8c36302a4cd45ab3caa7ae4/patch/kernel/rockchip64-current/board-nanopi-m4v2-dts-add-sound-card.patch#L64

I think you could probably replace i2s1 -> i2s0 in this node.

Share this post


Link to post
Share on other sites

@piter75Thanks for the head up. I know on t4 it's attached to i2s0 and the mixer settings discussed in the other threads. Maybe I should test the codec on friendlyarm's android image to make sure the hardware is working as I had never heard any playback since I got the t4.

Share this post


Link to post
Share on other sites

Hi, new Problems.

 

I need the package "Debmatic"  https://github.com/alexreinert/debmatic/blob/master/docs/setup/armbian.md

 

min. Kernel 4.9 and for NanoPi M4 with RPI-RF-MOD (40pin) a Dev kernel 

 

After this:

apt install pivccu-modules-dkms

 

comes that: 
Unpacking pivccu-modules-dkms (1.0.36) ...
Setting up pivccu-modules-dkms (1.0.36) ...

Creating symlink /var/lib/dkms/pivccu/1.0.36/source ->
                 /usr/src/pivccu-1.0.36

DKMS: add completed.
Error! Your kernel headers for kernel 5.4.0-rockchip64 cannot be found.
Please install the linux-headers-5.4.0-rockchip64 package,
or use the --kernelsourcedir option to tell DKMS where it's located
Created symlink /etc/systemd/system/multi-user.target.wants/pivccu-dkms.service → /lib/systemd/system/pivccu-dkms.service.
Created symlink /etc/systemd/system/debmatic.service.wants/pivccu-dkms.service → /lib/systemd/system/pivccu-dkms.service.
Created symlink /etc/systemd/system/pivccu.service.requires/pivccu-dkms.service → /lib/systemd/system/pivccu-dkms.service.
Processing triggers for libc-bin (2.28-10) ...
 

had some one an idea why kernel headers cannot be found.

i tried it also with armbian config.

 

The RPI-RF-MOD module is not detected by pivccu -info

 

please help:(

Share this post


Link to post
Share on other sites
1 hour ago, Enrico said:

Error! Your kernel headers for kernel 5.4.0-rockchip64 cannot be found.

The headers package is not bundled in Armbian image and when you install it you are actually installing the last "stable" version of them in "current" target - which right now is 5.3.11

NanoPi M4V2 image was never built with 5.3.11 kernel and that's why the installed header do not match the kernel.

 

One thing you could try as a "creative workaround" would be to upgrade kernel which will actually downgrade it to 5.3.11 and then the kernel and headers packages should match.

I just did it on a freshly downloaded image for NanoPi M4V2 with kernel 5.4.2 from Armbian downloads and it worked fine, however YMMV ;-)

You better test it first on a spare SD card if you already did a lot of tuning to the current install.

 

EDIT: I assumed you downloaded my image linked a few posts back.

If you did build your own image you can transfer a headers package from "output/debs" folder to you machine and install it there without the need for downgrading kernel.

Share this post


Link to post
Share on other sites
8 hours ago, Enrico said:

how to downgrade to 5.3.11

 

sorry for my terrible english:angry:

Run armbian-config. This tool can help you switch between kernels.

Share this post


Link to post
Share on other sites
8 hours ago, Enrico said:

how to downgrade to 5.3.11

 

40 minutes ago, Werner said:

Run armbian-config. This tool can help you switch between kernels.

That's true but you can also run the following commands.

This will "upgrade" to the latest "current" kernel from Armbian release 19.11.3, which is 5.3.11.

That's why I said you can downgrade via upgrading... ;-)

 

sudo apt dist-upgrade
sudo reboot

 

Share this post


Link to post
Share on other sites

Hi,

first of all, thanks a lot to the great work.

I have downloaded the server version with 5.4.2 kernel and have some problems with wifi.

At first it works quite well, but after apt-get update, upgrade and rebooting the wifi didn't work anymore.

 

With the desktop version wifi is working also after upgrading.

 

So what could cause the problem?

 

Thanks

 

Edited by mad

Share this post


Link to post
Share on other sites
4 hours ago, mad said:

So what could cause the problem?


That upstream packages needs updating which will happen at next release. Not before since this is testing build and issue is not critical.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
9 9