Get for Free Station P1 rk3399, M1 rk3328

Recommended Posts

There are 2 packages that don't seem to download, all the others do.

Err:382 hirsute/main arm64 libvpx6 arm64 1.9.0-1
  Error reading from server. Remote end closed connection [IP: ::1 3142]

Err:419 hirsute/universe arm64 librubberband2 arm64 1.9.0-1
  Connection timed out [IP: ::1 3142]

Fetched 595 MB in 4min 53s (2035 kB/s)
E: Failed to fetch  Error reading from server. Remote end closed connection [IP: ::1 3142]
E: Failed to fetch  Connection timed out [IP: ::1 3142]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
[ error ] ERROR in function create_rootfs_cache [ ]
[ error ] Installation of Armbian desktop packages failed 
[ o.k. ] Process terminated 
[ o.k. ] Unmounting [ /home/nicod/build-desktop/.tmp/rootfs-9fd0506ee413f6916aff1957275eafda/ ]
[ error ] ERROR in function unmount_on_exit [ ]
[ error ] debootstrap-ng was interrupted 
[ o.k. ] Process terminated 

Maybe because it's hirsute?
I'll try building a focal. I should do this with ethernet to be sure. And maybe with the N2+. I'll put it next to my router and ssh.
This morning was just the kernel.

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

14 часов назад, NicoD сказал:

It didn't work :( no images in output. I'm trying again to see what's going wrong. 


18 часов назад, NicoD сказал:


You have specified a kernel-only build.  :)

I recommend that you start setting build parameters via the GUI (run the command without parameters). 




The system will offer you a graphical interface for sequentially selecting all the parameters and at the output you will get a non-compressed image that you can write to the media.



Link to post
Share on other sites
8 hours ago, balbes150 said:

Start by building a server image, it doesn't need a lot of packets and traffic.

That worked. I've got the image in /output/images. Still need to test the image. But seems ok.

[ .... ] Updating initramfs... [ update-initramfs -uv -k 5.9.16-rockchip64 ]
[ o.k. ] Updated initramfs. [ for details see: /home/nicod/build-desktop/output/debug/install.log ]
[ .... ] Re-enabling [ initramfs-tools hook for kernel ]
[ o.k. ] Unmounting [ /home/nicod/build-desktop/.tmp/mount-865a5d3b423ee6bce9320d2ec8206f44/ ]
[ o.k. ] Free SD cache [ 71% ]
[ o.k. ] Mount point [ 89% ]
[ o.k. ] Writing U-boot bootloader [ /dev/loop0 ]
[ o.k. ] SHA256 calculating [ Armbian_21.02.0-trunk_Station-p1_hirsute_current_5.9.16_.img ]
[ warn ] GPG signing skipped - no GPG_PASS [ Armbian_21.02.0-trunk_Station-p1_hirsute_current_5.9.16_.img ]
[ .... ] Fingerprinting 
[ o.k. ] Done building [ /home/nicod/build-desktop/output/images/Armbian_21.02.0-trunk_Station-p1_hirsute_current_5.9.16_.img ]
[ o.k. ] Runtime [ 67 min ]
[ o.k. ] Repeat Build Options [ ./  BOARD=station-p1 BRANCH=current RELEASE=hirsute BUILD_MINIMAL=no BUILD_DESKTOP=no KERNEL_ONLY=no KERNEL_CONFIGURE=no COMPRESS_OUTPUTIMAGE=sha,gpg,img  ]


Link to post
Share on other sites

The server image does work. And I might have found what the problem is. There's a server not found in apt repos.

Get:1 hirsute InRelease [269 kB]
Hit:2 hirsute-security InRelease                       
Hit:3 hirsute-updates InRelease
Hit:4 hirsute-backports InRelease
Ign:5 hirsute InRelease
Err:6 hirsute Release
  404  Not Found [IP: 443]
Reading package lists... Done
E: The repository ' hirsute Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Unable to install the Armbian desktop with armbian-config.
I was able to install ubuntu-mate-desktop. Doesn't boot into desktop but can start it with startx.
I think the reason my SBC builds didn't work was because I always tried hirsute desktop. All others worked. So I'm happy to know I now can easily build images with my SBCs.
Wasn't an ARM problem.
I'll need a new 12V adapter so I can put my N2 next to my router as build server. The P1 stole the N2 its adapter.
I'm glad the troubles been found because I was starting to doubt in myself :) Thank you @balbes150
Video coming soon.

Link to post
Share on other sites
1 minute ago, Werner said:

Had the same issue. The reason was that I did not create another user than root. lightdm refuses to start if there is no normal user present.

I did create my user before installing the desktop. Was logged in with my user when installing the desktop. It doesn't seem to perform very good. So nothing here to see for me. 

Link to post
Share on other sites

@IgorI'm making a video about building Armbian images on Armbian. I've got a few question I'd need to answer before I can finish it.
1. Does this work on other distros than Focal? (I only tried it on Focal)
2. Does this work on armhf? (I guess not)
3. Will the /lib64/ file be installed by default on supported Armbian images? Any link to that files for download?
4. Anything else I should know?

I've now build 3 different images successfully. So I'm convinced the problems I had were just with the Hirsute desktop.
I'll make a video now about building on arm. Later I will make a video about all the different desktops. But I'll already talk about it here.

Link to post
Share on other sites
2 minutes ago, NicoD said:

1. Does this work on other distros than Focal? (I only tried it on Focal)
2. Does this work on armhf? (I guess not)
3. Will the /lib64/ file be installed by default on supported Armbian images? Any link to that files for download?
4. Anything else I should know?

1. Probably works, but elsewhere was always a lottery / unsupported.

2. Try. I didn't.

3. Once we will support this type of building, we will ship what's needed. Currently this is still formally in development and it doesn't have high priority. Desktop has. We are aware that certain things doesn't work at all.

4. Desktop and native arm building is still months to go to reach v1.0 / user level. We plan to merge support in 1/2021 but only XFCE setup will be officially supported. Further official support will remain dependent from community involvement. We expanded that tool can handle desktops pretty easy, but maintaining more than 1-3 configurations is not planned / not possible. We are also considering partnership with desktop designers, which could develop this further. Our focus was not to provide good looking desktops with top UX. We actually didn't do anything about that ... we were focused only on a framework which now supports much easier desktop development ...


Building latest trunk Ubuntu userland is related with a great portion of luck and its most likely not related to our build engine. There are no plans nor resources to support Canonical beta userland development. Official Armbian support will be tied to stable / LTS versions as we do it since ever.

Link to post
Share on other sites
1 час назад, NicoD сказал:

3. Will the /lib64/ file be installed by default on supported Armbian images? Any link to that files for download?

I planned to create a simple DEB package with these files for easy installation as a dependency of the build environment, but so far there is not enough free time for this (after creating the package, it still needs to be placed in a network repository and check how it will work on different versions of distributions). So for now, I limit myself to "simple dumb copying" and including these files in all my images. :(


p.s. Unfortunately, those who want to help, at least in such simple operations, are not observed. Everyone wants to get everything for free, beautiful and that everything would work out of the box ....

Link to post
Share on other sites
6 minutes ago, balbes150 said:

and including these files in all my images.

No problem. I've said it's still in beta and it is best to use one of your images to build. I'll link to your download page.
I also show the /lib64/... file that is needed.
Thank you for your amazing efforts and help(and @Werner and @Igor and the others).
I'd love to help out more with coding, but then I'd have no time left for my tasks like making videos.
And I'm no coder anymore, I don't have the overview that I used to have. Brain damage makes me be not so smart :mellow: You don't need to be smart to be happy :D

Link to post
Share on other sites
8 минут назад, NicoD сказал:

I'd love to help out more with coding, but then I'd have no time left for my tasks like making videos.

You do your job well.  :)

It is not necessary to know everything, in the modern world only specialization in a narrow direction will allow you to achieve good results. Unfortunately, the number of "narrow specialists" who work on the development of Armbian is scanty and they have a huge load ....

Link to post
Share on other sites
13 часов назад, NicoD сказал:

No display, the heartbeat led is on. 

Try using my "armbian-tv-next" branch to build images for P1\M1. It has changes that use a different kernel for legacy. I am not creating a PR yet, until it is agreed with the rest of the interested developers which legacy kernel is best to use for P1\M1.

Link to post
Share on other sites
1 hour ago, balbes150 said:

that use a different kernel for legacy

If we are talking about moving the P1 from RK3399 to rockchip64, I don't know, my opinion is do what is best. But if we are talking about introducing a completely new Legacy kernel, I think it is a very bad idea. Two kernels is already a mess for RK3399 boards, and introducing a third one would be a nightmare.


I suggest it is better to do some work in making the P1 work with some of our existing kernels. After all, the P1 came into scene just a few weeks ago, it is normal that everything is not working yet.

Link to post
Share on other sites
6 hours ago, Werner said:

would be nice to get your opinion

Ultimately we should have a single kernel source for all rockchip64 devices ;p

At this point neither rockchip64 nor rk3399 is really fit for that. They do not support rk3308 as a simple example. It should probably be some more or less stable cut from Rockchip's master.

Until recently I was actually more inclined to move devices from rockchip64 to rk3399 and make it a base for switching to Rockchip's master whether it would be 4.4 or 4.19 (FriendlyElec is already using 4.19 for R4S).


On the other hand boards are now divided ~50/50 between those kernels so we can move Station P1 to rockchip64 if it fits there better.

We will worry about switching to some form of Rockchip's master later - most probably not earlier than with first rk3568 boards...


8 hours ago, balbes150 said:

There is no "new" kernel for P1, I use the rockchip64 kernel

As stated above I see no harm in that.

Link to post
Share on other sites
41 minutes ago, NicoD said:

And the price also gone up. But will you receive it when you order??? I asked the seller what's wrong and didn't get a response. Too bad, I really wanted to try this. 

I had the same.

They explained after a few days that it had some outgoing customs issues and asked me to place the order again.

Yesterday I opened a dispute which was resolved by Aliexpress within an hour in my favour and today I got the money back.

Seeing how well it went with the dispute I ordered it again - it was 0.25EUR more expensive now. Let's see how it fares this time ;-)

Link to post
Share on other sites
3 hours ago, balbes150 said:

@NicoD Can you shoot a video on how to download and burn an Armbian image to an SD card using only a regular Android on P1 ? I. e. I am interested in a video how to run Armbian with only P1. This instruction allows any user, without any additional devices (PC, laptop, etc.) to get a working Armbian on any supported device. :)

That's a good idea. I'll see what tool is best used in Android to burn the image. I've never used android for it, but since people with P1/M1 certainly have Android it is a great idea.
I've got a video planned where I show a full installation of Armbian Buster Legacy. I can start it in Android. I'll make the video when my NVMe hat arrives. Thanks for the idea. I wouldn't have thought about it. 

p.s. I've got a Mecool KM6 with S905X4 to review Android 10 on it. I don't suppose there will be Armbian for this? Just asking so I don't say anything wrong. 
I like the box, but I can't get used to Android. For watching video it's ok, but for productivity tasks it is bad.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.