H6 boards: Orange Pi One Plus, Orange Pi 3 Plus and Pine H64

Recommended Posts

2 minutes ago, valant said:

How about command line hand off? Do you know how it's passed in case of using DT (thus no ATAGs)?


I don't know actual implementation details, but defining "bootargs" variable with "booti" command works, since I'm using that during development... I think I heard that bootm doesn't work with aarch64 kernels and I didn't even try it.

Link to post
Share on other sites
Donate and support the project!

3 hours ago, jernej said:


I don't know actual implementation details, but defining "bootargs" variable with "booti" command works, since I'm using that during development... I think I heard that bootm doesn't work with aarch64 kernels and I didn't even try it.

yes, I saw that on the armbian for pine64. it both uses booti and sets up bootargs.


bootm works for sure. in that sense it switches into aarch64 state, masks out interrupts as well as booti does, and successfully loads and transfers control to "legacy linux image". but that image wasn't actually linux. :) As I've said, without arguments to it, it passes zeros into 4 argument registers. It's hard to check what it would do with DT loaded and passed to it, when the code cannot do anything with DT by its own yet. Of course, for bootm, a so called arm64 linux image format isn't a thing (mkimage wrapping needed).



I found the answer. "bootargs" goes into "/chosen" node.

Link to post
Share on other sites
5 hours ago, eperie said:

Thank  you Igor - I should be able to make my way through  Armbian's build system at one point.

If you don't need to change anything, just run the build script (add EXPERT="yes" to have access to WIP builds) select board, kernel if there is more than one, userspace, desktop or CLI ... wait and you end up with a kernel/image. WIP area sometimes breaks and here we don't provide assistance. It's too complex/expensive ... but stable builds must work and they usually build just fine. If you are using a recommended way of building. If you plan to build manually, without a help of our build system, there might be many things to fix before.

Link to post
Share on other sites

I've been trying to build an image for OrangePi One Plus today (with Vagrant/VirtualBox) but all I get when answering the questions from the menu is :


Error: Expected at least 5 tokens for --menu, have 4.
Use --help to list options.

[ error ] ERROR in function source [ main.sh:188 ]
[ error ] No kernel branch selected
[ o.k. ] Process terminated


Link to post
Share on other sites
2 hours ago, gounthar said:

Error: Expected at least 5 tokens for --menu, have 4.
Use --help to list options.

[ error ] ERROR in function source [ main.sh:188 ]
[ error ] No kernel branch selected
[ o.k. ] Process terminated

dev image only.. so you need a EXPERT="yes" tag set. Background: All sunxi boards share mostly the same kernel. Due to H6 initial support is based somewhere on top of 4.17 (probably partly 4.16), armbians "next" kernel (4.14) isn't an option for this board. 

Link to post
Share on other sites

Sorry for bothering you with stupid questions, but I launched:

vagrant@ubuntu-xenial:~/armbian$ sudo ./compile.sh BOARD=orangepioneplus KERNEL_ONLY=yes RELEASE=stretch EXPERT=yes

My config file is :

# Read build script documentation http://www.armbian.com/using-armbian-tools/
# for detailed explanation of these options and for additional options not listed here

KERNEL_ONLY="no"                                # leave empty to select each time, set to "yes" or "no" to skip dialog prompt
KERNEL_CONFIGURE="no"                   # leave empty to select each time, set to "yes" or "no" to skip dialog prompt
CLEAN_LEVEL="make,debs,oldcache"        # comma-separated list of clean targets: "make" = make clean for selected kernel and u-boot,
                                        # "debs" = delete packages in "./output/debs" for current branch and family,
                                        # "alldebs" = delete all packages in "./output/debs", "images" = delete "./output/images",
                                        # "cache" = delete "./output/cache", "sources" = delete "./sources"
                                        # "oldcache" = remove old cached rootfs except for the newest 6 files

DEST_LANG="en_US.UTF-8"                 # sl_SI.UTF-8, en_US.UTF-8

# advanced
KERNEL_KEEP_CONFIG="no"                 # do not overwrite kernel config before compilation
EXTERNAL="yes"                          # build and install extra applications and drivers
EXTERNAL_NEW="prebuilt"                 # compile and install or install prebuilt additional packages
CREATE_PATCHES="no"                     # wait that you make changes to uboot and kernel source and creates patches
BUILD_ALL="no"                          # cycle through available boards and make images or kernel/u-boot packages.
                                        # set KERNEL_ONLY to "yes" or "no" to build all packages/all images

BSPFREEZE=""                            # freeze armbian packages (u-boot, kernel, dtb)
INSTALL_HEADERS=""                      # install kernel headers package
LIB_TAG="orange-one-plus-ethernet"                      # change to "branchname" to use any branch currently available.


and then, I got

  AR      net/built-in.a
[ error ] ERROR in function compile_kernel [ compilation.sh:364 ]
[ error ] Kernel was not built [ @host ]
[ o.k. ] Process terminated

I'm sure I missed something, but can't see what for the time being.

Link to post
Share on other sites
16 minutes ago, gounthar said:

Sorry, I am working on a fork (I haven't changed anything yet, I just created a new branch to work on the Ethernet part for the DTS).

Aha. I am working on an Allwinner patches cleanup. Perhaps you could join? 

I haven't try to build H6 images yet, but I think you need to enable NEXT in board configuration since we only have NEXT kernel, v. 4.17.y ... 4.18.y when it's ready. This whole part will be merged into master when current regressions are solved and when its tested well enough.

Link to post
Share on other sites
11 minutes ago, gounthar said:


I would be happy to join, as long as I don't break everything. :rolleyes:


You will not get commit rights, so you will not be able to break anything :) You can try to work on some features which were not be addressed and when you have a working solution, patch, you send it to Github as PR. I am just pointing you to the latest sources, that you will not deal with something that has already been solved.


12 minutes ago, gounthar said:

I had been told not to use NEXT for these boards, or I did not understand correctly maybe...

It is true in both cases. On build script branch sunxi-4.18, NEXT was already moved to 4.17.y, while master branch have NEXT on 4.14.y and DEV on 4.17.y or 4.18RC ... it doesn't matter. Just read my post once again :)

Link to post
Share on other sites

my fault.. :P 

Didn't have the 4.17 branch in mind (didn't know that you started with a 4.18 branch). So the statement is true for the masters branch where next is 4.14 and h6 boards only live in the dev branch. This is different for the 4.17/4.18 branch. So you might build your branch on top of them and then send PRs against those and not master. :) @Igor will it make more sense to buid against 4.17 or 4.18?


9 hours ago, Igor said:
17 hours ago, gounthar said:



Where did you find this? We don't have it. 

IMO it actually makes sense to name it different than armbians default names in case your git-fu is on a similar level than mine (in case a PR gets rejected it's just less work to sort this stuff out than to revert the git-history from the working branch and sync it properly with armbians branchnames, I can, but it takes me more time than just kill a dedicated branch for my idea).

Link to post
Share on other sites

Thank you very much for armbian 5.55 development 4.18 for PineH64.  i have only two maybe stupid questions.: why board is recognized only 2 GB RAM not 3GB. ( i know it is development )

Second question about cpu frequency. 1.49GHZ. Why dont you decided on full 1.80GHZ. Pine's board are good projected if you mean hot. Board stay cold. I used to only 3,5 cm x 3,5 cm radiator. Tested yotube play video 480p and things not going wrong ( hot )

Did you tested frequency trotting? I thing this board can reach 1.8GHZ. Iam curious your opinion. Best regards.  

Link to post
Share on other sites


I have tried to boot the OrangePi One Plus image on my Beelink GS1, but either the UART is bad configured or I have damaged the TXD pin :'(.

I can't stop the U-boot nor enter a login.


bootlog : https://pastebin.com/Rd2EEduZ


I try to get some information from the 

sys_config.fex (from gs1_rv106N0.img): https://pastebin.com/TdnfRMJL

reverse dts: https://pastebin.com/jK2zhGAe


Everything seems correct so maybe I have damaged the TXD pin.

Do you think there is lot of work to make ethernet/ssh works one my board ?




Link to post
Share on other sites

Hi @froezus,


how did you boot this on the Beelink GS1 just burned the image with Win32Diskimage and it automatically booted from SD card, after modifiyng the fex file in the Orangepi image from the GS1 image sys_config_fex?


no other changes ?


were are the UART pins on the board, i got such a device here, i could open it up and start some testing.....


best regards



Link to post
Share on other sites
On 1/30/2018 at 5:55 AM, Noah E. Koeppel said:

Oh, it's not too hard but there are no instructions really, should be the same for all H6 boards for windows (not 100% sure about wifi): 

  1. Download PhoenixCard 4.1.2 (3 might work but 4 works better)
  2. Download the image for your device http://www.orangepi.org/downloadresources/
  3. Use PhoenixCard in StartUp mode to burn the image to a microSD (class 10 or higher recommended https://www.sdcard.org/consumers/choices/speed_class/img/video_speed class_01.jpg)
  4. Insert and boot.

Now you can do stuff to it:

  1. Enable USB0 device mode in Settings->Developer Options
  2. Install ADB (there's lots of ways but this will make it easy https://forum.xda-developers.com/showthread.php?t=2588979)
  3. Download the AFWall+ apk from github (https://github.com/ukanth/afwall/releases)
  4. Open a command window and type "adb install pathto/AFWall.version.apk"
  5. Download the Zidoo H6 Pro 1.0.10 OTA zip from https://forum.xda-developers.com/android-stick--console-computers/allwinner/zidoo-h6-pro-android-7-0-allwinner-h6-2-t3682338
  6. Open a command window and type "adb push pathto/ZIDOO_H6_Pro_20170930_v1.0.10_ota.zip /sdcard"
  7. Type "adb reboot recovery"
  8. MAKE SURE YOUR BOARD IS NOT CONNECTED TO THE INTERNET (If you have an ethernet connection make sure it is unplugged, if you have wifi make sure it doesn't connect to the internet)
  9. Choose "Apply update from Internal" and select ZIDOO_H6_Pro_20170930_v1.0.10_ota.zip (this will take a while but be patient and it will eventually reboot)
  10. You should now be booted into the Zidoo launcher, you should first open AFWall+ and set it to blacklist mode, then select the item that includes "Input Devices" in the description and enable the firewall from the settings.
  11. You can now connect to the internet and sign into google.
  12. Download SuperSU from google play or install it from adb.
  13. Open SuperSU and update binaries using the normal method.

Congrats, you have rooted android with play services

Unfortunately the rom forces the ui to hide itself systemwide so you have to drag from the top or bottom to access notifications and navigation.  If you want to use your pi as more of a tablet this can get annoying and if anyone has a fix i'd love to hear it but Zidoo certainly isn't in a hurry to change anything for us pi users.

I tried to install ZIDOO_H6_Pro_20170930_v1.0.10_ota.zip to your OrangePi One Plus, but when you run 9 point I stalled. How to choose "Apply update from Internal"? How do you sort out items in recovery? OrangePi One Plus has only one button that reacts in this mode. I will be glad to any hint.

Link to post
Share on other sites
41 minutes ago, andrw said:

Latest nightly images for Pine H64 don't contain "desktop" version. Will it be added later?

Why it should be? Images are made for development and testing purposes. If you need to test a desktop -> armbian-config -> system -> enable desktop

Link to post
Share on other sites

There are such an images for previous builds, so it was unclear. Ok, thanks.


I still have nothing in serial console on Pine H64. Could anybody please point any known good image for this board? I'm not sure what is the reason, but my rockpro64 boots Armbian fine and console is active there.

Link to post
Share on other sites

Just nothing but I just realized that UART pins were connected with same names (RX<->RX, TX<->TX) and this is the problem.
Reconnected and now this build boots fine for me: "ARMBIAN 5.86.190513 nightly Debian GNU/Linux 9 (stretch) 5.1.0-sunxi64"
Sorry for the noise.

Link to post
Share on other sites
5 hours ago, magicstone1412 said:

in Development forum

because new user write into the dev forum instead of  review their own actions and look for a solution.

Because of that there is an own section in the forum:

Board doesn't start

 SD card and PSU issues

Or if you want to read a current posting that goes in that direction.


So until you have gathered some basic experience,  supporting others,  you are blocked from writing to the dev forum, but everywhere else is open.

If you are here for a couple months on a regular basis, you will understand.


Link to post
Share on other sites

Rgd OpiOnePlus image...

Currently I do not use the board, but l recall a discussion somewhere whether the port is an USB3 one or USB2 one?


Anyway according to Xunlong it is not ( no longer ) while in downloads " USB3 sometimes doesn’t detect high-speed devices properly " can be read ?

This has to do with latest changes rgd usb3-now-working ( as well planned for kernel 5.5. )?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.