1 1
Rfreire

New forum UI!!

Recommended Posts

(edited)

For what is worth, works great with my intentionally un-updated iPhone 6 iOS 9 :P:P

 

Edit: because... Old people are cranky!!! Get off my lawn slowing down my phone with new iOS, Apple!

Edited by Rfreire

Share this post


Link to post
Share on other sites
18 minutes ago, talraash said:

Any chance for black... or not white forum theme?


If you find one dark that works perfectly well. I can add it and adjust.

 

1 minute ago, TonyMac32 said:

I had to manually switch back to Armbian theme as well, Android 8/ Chrome

 

I'll see how can I force change for all users. 

Share this post


Link to post
Share on other sites

I get a bunch of approval messages for stuff which is already approved..  From the experience I had before.. those didn't show up that much when they were approved by another mod before (not 100% but more). Seems once more that the UI isn't really friendly for low resolution displays like mine (13XX) but at least coding template works quite well even when not fullscale window. :) Seems that there is a 'Add tag' feature which is broken:

Sorry, there is a problem

There are no tags available
Error code: 2S131/3

 

 

Share this post


Link to post
Share on other sites

Also it would be nice to remove the "Newsletter" box from the Activity pages, and at least for me nick and date separators for the posts on the main page are broken (most likely theme related):

DLink - DWA 131 - Rev E1- …
By Mustafa85base_forum_author_date_sep
Yesterday at 01:03 PM

 

Share this post


Link to post
Share on other sites
6 minutes ago, chwe said:

Yet an other small error..

It looks like a theme issue, let's collect more and report here:
https://invisioncommunity.com/forums/topic/439176-haze-42x-by-ips-themes/?page=2

 

8 minutes ago, chwe said:

Code highlighting is done by CKEditor right?


Right.

 

Quote

To customise how the editor looks, Invision Community uses CKEditor Skins. You can obtain new skins for the editor from CKEditor's website (must be compatible with version 4.9). Each theme can use a different editor skin.

 

Share this post


Link to post
Share on other sites
15 minutes ago, Igor said:
25 minutes ago, chwe said:

Code highlighting is done by CKEditor right?


Right.

so,  'CodeSnippet' should be part of CKEditor core.. 

Adding: 

codeSnippet_languages:
  bash: 'Bash'

might do the work.. 

 

According to this one:

https://invisioncommunity.com/forums/topic/415860-syntax-highlighting-plain-code-option-please/

 

this should be possible. 

 

https://ckeditor.com/cke4/addon/codesnippet

 

And it is compatible with 4.9 and also actively maintained... Maybe the symbol looks than a little bit different.. 

Share this post


Link to post
Share on other sites
1 hour ago, JMCC said:

Got it! Now you need to click twice on the icon.

hmm... sounds familiar... :P 

 

 

btw.. the like looks a bit messed up (looks quite that they wanna implement more reaction possibilities - I think we had this once before but disabled it?).

like.jpg.1fec56a2109e84848fb025a787b199a7.jpg

quote is also a mess.. the button shows up random somewhere on my browser.. :P  --> maybe a 'opera only' feature? :P 

 

 

 

 

Share this post


Link to post
Share on other sites

I see two things... one minor cosmetic, the other bloody annoying! :P

 

Firstly the bloody annoying 'feature'... :lol:

image.png.57e2a29b7dcb4fc54b0459b91e9d428b.png

 

And then the minor cosmetic detail... probably a legacy of the multi-reaction thingy... you mouse over the heart, that grey slider starts trying to pop out...

 

image.png.eb4bfa64a504b04d72df46ecf07b36f0.png

 

On Chrome, Windows 10. 

Share this post


Link to post
Share on other sites
Just now, Rfreire said:

Hi @Igor!

 

Still no Shell syntax highlighting in the new extension?


I haven't read posts here and install anything yet since I do try to get some rest on weekends ... It has been a busy week and upcoming looks even more. Fixing cosmetic issues on a forum has low priority and can wait for a while. In any case, I will seek help from theme designer since I don't want to spend precious weekends solving this. 

Share this post


Link to post
Share on other sites

No worries at all. Just stating the obvious, in case no one else raised the flag!

 

Add to the bucket list ;-)

 

Thank you very much for your efforts.

Share this post


Link to post
Share on other sites

Another bug. Wrong picture when posting a forum link to the facebook. 

 

Now we have random(?) avatar with the link:

image.png
 

 

Before:

image.png

Share this post


Link to post
Share on other sites

I must admit, that the Armbian forum isn't the only forum that I visit regularly. Therefore I'm aggregating various forum posts as RSS feed via feedly. @Igor If you have the time you might check the forum RSS export function. RSS feeds from other forums contain additional metadata, like the author's nickname or real name.

Share this post


Link to post
Share on other sites
3 minutes ago, umiddelb said:

RSS feeds from other forums contain additional metadata, like the author's nickname or real name.


I don't use this function ... was this working properly before this update?

Share this post


Link to post
Share on other sites
1 minute ago, Igor said:


I don't use this function ... was this working properly before this update?

No, the update didn't have an impact. This is something I'm missing for a longer time. The RSS feed itself is working like before.

Share this post


Link to post
Share on other sites
25 minutes ago, Igor said:

I don't use this function ... was this working properly before this update?

Looks like some RSS settings can be changed by creating custom feeds in Forums-Settings section in AdminCP, but I don't have permissions to do that.

Share this post


Link to post
Share on other sites

Do you have a problem with logging in using tapatalk? I'm getting "server error occured: 256 Class .... could not be loaded...", like on screenshot attached.

armbian_forum_tapatalk_login.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1