1 1
JMCC

S905(x) ALPHA media capabilities testing script

Recommended Posts

Well, no fancy introduction here, because this doesn't pretend to be a script for the general use, only for testers who want to try the current *very early* status of the media capabilities in the Armbian meson mainline kernel.

 

Warning: It will replace your current kernel with a pre-compiled nightly 4.19.20.

 

Instructions:

Download, untar and run. If you need further instructions, then you are not ready for this script (again, it is very unpolished, not for general use).

 

Download link: https://mega.nz/#!YvYUhayC!CI1fl52V4tV0G4oqUib4W-NlMpVSpLDp8kmo74g-V08

 

Things that you can try with this script, on a X session:

 

  • Use a 1080p@30fps h264 video, and play it with "mpv -hwdec <filename>". You'll see in the logs that it is decoding through v4l-m2mcopy
  • Install and run glmark2-es2
  • Use Chromium WebGL
  • Play a 1080p@30fps video in YouTube in full-screen smoothly. I'm pretty sure it is not really using HW decoding as it claims (there is no  initialization message in dmesg), but it's smooth for sure.

 

Gstreamer is tested not to work, in some other forum I was told that Bionic version is not enough and I need to compile a newer one.

 

Performance is not in any way good, but it is a starting point. Anyway, the first TO-DO is getting the mali module integrated into the kernel, so there is no need to compile it separately.

Share this post


Link to post
Share on other sites

I propose to make a change to the script. Build the MALI module itself directly on the production system with the current kernel. Check for kernel headers, if available, install the sources for MALI and run the build of the MALI module on the current system.

Share this post


Link to post
Share on other sites
1 hour ago, balbes150 said:

I propose to make a change to the script. Build the MALI module itself directly on the production system with the current kernel. Check for kernel headers, if available, install the sources for MALI and run the build of the MALI module on the current system.

Well, actually I tried to build it natively against the kernel headers, and it didn't work. I had to cross-compile it against the original kernel build tree. I must recognize that I didn't try too hard the first option, though.

 

However, what we really need is a way to integrate it into the main kernel build which, for some reason, seems to be harder than with other mali flavors. We are having the discussion about the subject on this other thread.

Share this post


Link to post
Share on other sites

I've tried to run your script on khadas vim, i am getting various errors when installing kernel and mali module, failed to read and cannot access archive, most of the stuff wasn't installed.

Share this post


Link to post
Share on other sites

Here is the log file, running on khadas vim, armbian 5.75., kernel 4.20.5.

 

Maybe i am missing some packages?

install.log

 

To anyone who has problems with installation, use Midnight commander, it works with it!

Share this post


Link to post
Share on other sites

Found a small error in the script. No links to the installed libMali file are created (not copied) during the installation process. In the system at this point is the same files from the shared installation. If manual overwrite these files with links to liBmali, begins to work MPV full screen. Gstreamer I have not yet been able to run, it gives an error, I need to see what can be fixed. I tried the usual Chromium from (not 32 bit) the after fixing the libraries, now the video from YouTube works at full screen with almost no brakes at the desktop resolution 1080 and if you choose a video with the parameter 1080. When displaying video in the browser window, noticeable braking and artifacts.

Share this post


Link to post
Share on other sites

Perhaps to enable HW for the browser, you need to rebuild its Chrome-ffmpeg package using the new options (using hardware decoding v4l2m2m) ? By default, this package does not use the new decode type.

Share this post


Link to post
Share on other sites
On 2/11/2019 at 7:52 PM, Tommy21 said:

Here is the log file, running on khadas vim, armbian 5.75., kernel 4.20.5.

 

Maybe i am missing some packages?

install.log

 

To anyone who has problems with installation, use Midnight commander, it works with it!



It looks like you weren't running the install script from the script's folder, but from some other directory. You must untar the tarball, cd into the created "media-script" directory, and run "./media-s905.sh"

Share this post


Link to post
Share on other sites

I just tried script out on my lepotato... glmark2 worked on the mali test... and mpv was able to play fullscreen blueray mkvs... still ironing out browser

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1