The list of models that are running Armbian (Amlogic, Rockchip, Allwinner etc)


Recommended Posts

A95X Z2

4GB/64GB, RK3318

HTB1dbY1X.H1gK0jSZSyq6xtlpXak.thumb.jpg.8688e874c5f9630496c47e0f950b2daa.jpg

Armbian_19.11.4_Arm-64_bionic_dev_5.5.0-rc2_desktop_20191228

Doesn't work: Wifi, Bluetooth

Does work: everything else

It is stable and relatively fast, considering low price. It is based on RK3318 chip so it's not really desktop replacement material. Video playback in chromium works very slow and VLC has issues playing higher resolution videos. Desktop environment seems to be GPU accelerated and browsing seems quite smooth. Kodi - LibreElec, plays videos smoothly, even in a bit higher resolution (fullHD). I haven't tried 4k, but I very much doubt it can. 

If I install Kodi in Armbian it can't play even  video resolutions such as 720p.

 

Armbian_19.11.5_Aml-g12_bionic_dev_5.5.0-rc5-next-20200110_desktop is newer, but USB3 stopped working.

Link to post
Share on other sites
Donate and support the project!

Magicsee N6 Max

Armbian_20.05.0-trunk_Arm-64_bionic_current_5.5.1_desktop_20200218

rk3399-rock-pi-4-2.dtb (tweaked to run 1.7 and 2GHz)

rk3399-rock-pi-4-2.dtb rk3399-rock-pi-4-2.dts

 

Armbian_20.05.0-trunk_Arm-64_bionic_current_5.5.1_desktop_20200227

wifi works

 

Armbian_20.05.0_Arm-64_bionic_current_5.6.0-rc4_desktop_20200304

xorg colors seem overbright, losing details

 

Armbian_20.05.0_Arm-64_bionic_legacy_5.6.0-rc7_desktop_20200324

colors back to normal, wifi works for a while

 

Armbian_20.05.0_Arm-64_bionic_current_5.6.0-rc6_desktop_20200403

xorg overbright color is back

 

Armbian_20.05.1_Arm-64_bionic_current_5.6.0-rc7_desktop_20200404

color problem. Fixed by replacing uInitrd & zImage from 20200324

 

Armbian_20.05.2_Arm-64_bionic_current_5.7.0-rc1_desktop_20200416

Armbian_20.05.2_Arm-64_bionic_current_5.7.0-rc1_desktop_20200417 :thumbup:

 

https://github.com/150balbes/Build-Armbian/blob/master/patch/kernel/rockchip64-current/rk3399-adjust-txpbl-for-mtu-1500.patch

rk3399-rock-pi-4-2-adjust-txpbl-for-mtu-1500.dts

 

All sorts of things changed in the current dtb, so I added the new cpu speeds

rk3399-rock-pi-4-2-5.7.dts

On idle, cpu % by some kworker - tracked down to module brcmfmac (wlan)

so modprobe -r brcmfmac for now

 

Armbian_20.05.2_Arm-64_bionic_current_5.7.0-rc1_desktop_20200423 OK

Armbian_20.05.3_Arm-64_bionic_current_5.7.0-rc2_desktop_20200425 OK, seems better with memory management

Armbian_20.05.3_Arm-64_bionic_current_5.7.0-rc3_desktop_20200502 OK

Armbian_20.05.4_Arm-64_bionic_current_5.7.0-rc3_desktop_20200508 :thumbup:

Armbian_20.05.4_Arm-64_bionic_current_5.7.0-rc4_desktop_20200510 :thumbup:

Armbian_20.05.4_Arm-64_bionic_current_5.7.0-rc5_desktop_20200514 :thumbup:

Armbian_20.05.4_Arm-64_bionic_current_5.7.0-rc5_desktop_20200516 :thumbup: glamor: video clicks & pops no more

Armbian_20.05.5_Arm-64_bionic_current_5.7.0-rc6_desktop_20200522 :thumbup:

Armbian_20.05.5_Arm-64_bionic_current_5.7.0-rc6_desktop_20200525  :thumbup:

Armbian_20.05.5_Arm-64_focal_current_5.7.0-rc7_desktop_20200527

remove /etc/apt/sources.list.d/snwh-ubuntu-ppa-focal.list to update

Armbian_20.05.5_Arm-64_focal_current_5.7.0-rc7_desktop_20200529 ✔

Armbian_20.08.0_Arm-64_focal_current_5.7.0-rc7_desktop_20200531 ✔

Armbian_20.05.6_Arm-64_focal_current_5.7.2_desktop_20200612 ✔ desktop feels snappier...?

Armbian_20.05.6_Arm-64_focal_dev_5.8.0-rc1_desktop_20200616 ✔ wifi does not disappear, nope didn't last

Armbian_20.06.0_Arm-64_focal_current_5.7.2_desktop_20200619 ✔

Armbian_20.06.0_Arm-64_focal_dev_5.8.0-rc2_desktop_20200623 ✔

Armbian_20.06.0_Arm-64_focal_dev_5.8.0-rc3_desktop_20200629 ✔ 13hr uptime wifi still on

 

rk3399-rock-pi-4-5.7-1.dtb rk3399-rock-pi-4-5.7-1.dts

Armbian_20.05.6_Arm-64_focal_current_5.7.0-rc7_desktop_20200605 OK with rk3399-rock-pi-4-2-5.7.dtb, with rk3399-rock-pi-4-5.7-1 mpv locks up

 

20.09 20200904 5.8.5-arm-64

su -c 'echo 5 > /proc/irq/230/smp_affinity_list' # irq230 is USB3 port (xhci-hcd:usb7)

su -c 'echo 4 > /proc/irq/27/smp_affinity_list' # irq27 is eth0

sudo taskset -cp 4,5 $(pgrep Xorg) # pin Xorg to cpu 4&5

==> chromium Octane score 10k+

 

Link to post
Share on other sites
H96-MAX-X3-Amlogic-S905X3-Android-9-0-Sm

H96 Max X3

- Amlogic S905X3 SoC

- Gigabit ethernet (RTL8211F)!

- boots with meson-g12a-x96-max.dtb and standard aml color fix

- decent radiator (compiling for hours on all 4 cores doesn't overheat at all)

- installs on eMMC no problem

- warn - comes with unrooted Android

- like other aml S905X's no wifi/bt/sound by default

 

 

Link to post
Share on other sites

MX pro 4K

 

Amlogic S905

Mali-450

DRAM 1GB DDR3

Flash 8GB

 

Currently running Armbian_20.02.0-rc1.037_Aml-s9xxx_buster_current_5.5.0-rc6_20200205 with meson-gxbb-p201.dtb 

Ethernet and USB is working

Haven't tried eMMC install (it might not work from what I've seen), so only running it from SD.

WiFi chipset is RTL8189etv - not working (it did work on OpenELEC with gxbb_p200_1G_100M_RealtekWiFi.dtb if someone is interested in that)

Link to post
Share on other sites

For additions to previous post:

On 3/8/2020 at 12:31 AM, jimbob said:
H96-MAX-X3-Amlogic-S905X3-Android-9-0-Sm

H96 Max X3

- Amlogic S905X3 SoC

- Gigabit ethernet (RTL8211F)!

- boots with meson-g12a-x96-max.dtb and standard aml color fix

- decent radiator (compiling for hours on all 4 cores doesn't overheat at all)

- installs on eMMC no problem

- warn - comes with unrooted Android

- like other aml S905X's no wifi/bt/sound by default

 

 

 

After use DTB file from post:

With kernel 5.6 and 5.7 Wi-Fi working out-of-the-box, but recognizing as BCM4339/2 (proper name is BCM4335), on 2.4 and 5 (AC) mode.

To get Bluetooth working we need add firmware for BCM4335, get it from:

https://github.com/kszaq/brcmfmac_sdio-firmware-aml/blob/master/firmware/brcm/bcm4335c0.hcd

and put in folder "/lib/firmware/brcm" with name "BCM4335C0.hcd" and reboot.

 

Don't get working yet 3D acceleration and video encoding. 

Link to post
Share on other sites

 

 

Tanix TX8 Max

Amlogic S912

3 GB RAM DDR4

16 GB eMMC

 

Armbian_20.02.0-rc1.037_Aml-s9xxx with meson-gxm-q200.dtb

JwzeAg.jpg

Installed on the emmc without problems.

Don't get working yet 3D acceleration in game. Encoding video up to 1080p.

Work all right. Fanless the temperature rises to 70. With fan 30 degrees.

JwzSov.md.jpg

 

Link to post
Share on other sites
2248548699_pristavka-vontar-x3.jpg

Vontar x3 (Amlogic S905X3 SoC)

 

Most probably same circuit as H96 Max X3 see:

Confirmed to work with 

h96max-x2-test-bus80-gpu-volt.dtb from root-stas:

-HDMI w/ sound

-WiFi 802.11a/b/g/n/ac

-Bluetooth 4.0 after adding missing files

Not working yet GPU/VPU accel

Link to post
Share on other sites

I'm running some X96 Air 2/16 variants on Armbian with no issue.

They're quad-core S905X3 based and come with DDR3. They're also very compact which is great for my use.

Using the meson-sm610.dtb, ethernet works and HDMI works as well.

 

I have no clue about audio or wifi as I do not use a desktop environment :lol:

They also have 16GB of eMMC which can be flashed to host armbian

 

 

MhyCHBi.png

 

ngpF5HI.png

Edited by ThatUnknownGuy
Link to post
Share on other sites
  • SteeMan locked this topic
  • SteeMan unpinned this topic
  • SteeMan unlocked, featured, unfeatured and locked this topic
Guest
This topic is now closed to further replies.