11 11
Sergey2k

Armbian for Amlogic S905X3

Recommended Posts

3 hours ago, TheMojoMan said:

Finally, Panfrost is working on my X96 Max + :)

 

I have used todays build (Armbian_20.06.0_Arm-64_focal_current_5.7.6_20200630.img.xz) with the meson-sm1-sei610-2.dtb (see some posts ago) and then followed the instructions of the first post here. This is essentially the same procedure that @m][sko mentions in @NicoD's guide here (which did not work with the older Armbian image). In summary, after starting the system do the following

  • sudo sh -c "echo 'PAN_MESA_DEBUG=bifrost' >> /etc/environment"
  • sudo add-apt-repository ppa:oibaf/graphics-drivers
  • sudo apt update
  • sudo apt upgrade
  • sudo apt install ubuntu-desktop -y
  • sudo reboot

And then you can try it with Gnome/Gnome on Xorg/Ubuntu or Ubuntu on wayland.

 

I will post details later when I did some more testing. Especially, I am interested if it works with Xfce.

 

Thanks to all the great people that made this possible!!! Especially to @balbes150 and Alyssa Rosenzweig and coworkers!

Sounds Great! Is there any way to upgrade from 20.05_bionic to this new image? or you have to reflash the image to the card? Thanks to the Armbian Team for this great job! :)

Edited by rna

Share this post


Link to post
Share on other sites

Panfrost for Bifrost GPUs (G31, G52) is a very fresh development. Therefore it is no wonder that it is still very unstable.

 

Quick test results for 'Ubuntu on Wayland':

The desktop gets blurred after a short while. Especially text output. Supertuxkart crashes, Firefox crashes and sends you back to login. The only thing I tested that did not crash was glmark2-es2-wayland. But I did not have time to get a little deeper into it, yet.

 

I tried to get Panfrost running on XFCE4 but failed. The window manager (xfwm4) seems to be the problem. I read that somewhere else where they suggested to use 'kwin_x11' instead. But I was not able to start xfce4 with kwin. Even after changing 'xfwm4' to 'kwin' in the respective .xml-file Xorg tried to start 'xfwm' and failed to do so when I activated 'glamor' and 'Panfrost' in /etc/X11/xorg.conf.d/01-armbian-default.conf. When it is set to 'none' and 'Lima' it starts the desktop.

When I tried to remove 'xfwm4' by typing 'sudo apt remove xfwm4' it was output that 'xfce4' would be removed as well ...

Share this post


Link to post
Share on other sites

@nguyen I am planning on buying another s905x3 tv box and I would like to know about your experiences about the A95X F3 slim. It is the cheapest TV box I could find with relatively efficient process node and architecture (12nm and cortex a55)

Share this post


Link to post
Share on other sites
On 6/16/2020 at 11:23 AM, vanngocan said:

I am trying to install Armbian on Eachlink X3 Mini. I use image Armbian_20.05.6_Arm-64_bullseye_current_5.7.2_desktop_20200612.img with dtb file meson-sm1-sei610-ethfix.dtb (this is what I used for my X96 Air box).

It booted well from usb. However, ethernet does not work :(
Is there any way to fix this ethernet issue?

I plug SD card, box cannot start (blank led screen). I also tried toothpick but nothing appears. How can u boot with armbian for X3 mini????

vietnam ak?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
11 11