63 63
balbes150

ARMBIAN for Amlogic S905 and S905X (ver 5.44 =<)

Recommended Posts

39 minutes ago, Felipe Junior said:

I got this result with Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_icewm_20171226.img on my Mecool M8S Pro 2G / 16 S912. This time there was no kernel error or ZRAM, but still did not complete Boot. See the last screen it performs.

IMG_20180820_154109_HHT.jpg

Try the Armbian 5.55 with kernel 4.18

 

Share this post


Link to post
Share on other sites
1 hour ago, Reddwarf said:

Try the Armbian 5.55 with kernel 4.18

 

I had already tested it before it gave the kernel and ZRAM errors. It looks like my device does not want to work with Kernel 4.18 or I did something wrong before. Although I do not have Axial Audio or Wi-Fi running. But finally the system started.

 

But I tried an older version and it worked. It was the version Armbian_5.37_S9xxx_Debian_stretch_3.14.29_xfce_20171226.img. The only change in method other than firmware was the fact that I extracted this time with 7Zipper.

 

My only concern now is that I made a stupid, not knowing what I was doing I installed the system in the EMMC, thus removing Android. Can I restore with USB Burn Tools?

 

 

Share this post


Link to post
Share on other sites

Another thing that bothers me is that I can not change the language, I have already been in the armbian configuration options but the system insists on not switching to other languages.

Share this post


Link to post
Share on other sites

I was able to install the stock system with the Amlogic Burn_Card_Maker method. Sempee does it that way and it has worked.

Share this post


Link to post
Share on other sites
4 hours ago, Felipe Junior said:

I was able to install the stock system with the Amlogic Burn_Card_Maker method. Sempee does it that way and it has worked.

Great, I use the Amlogic Burning Tool to flash Android and it works great.

Share this post


Link to post
Share on other sites

armbianmonitor -m doesn't check cpu temperatures anymore, it shows only cpu load and percentage?

 

Is there a working command to check cpu temperatures?

 

Share this post


Link to post
Share on other sites

On 150balbes 4.18.0-rc5 Ubuntu images, for those with T95 (p200) AML tvbox using meson-gxbb-p201.dtb / 200 device tree file, there is a problem with wifi caused by an error with nvram firmware files.
Problems manifests as wlan0 present but can't see any AP's.
To fix, use

 

mv /lib/firmware/brcm/brcmfmac4330-sdio.txt /lib/firmware/brcm/brcmfmac4330-sdio.txt.old
ln -s  /lib/firmware/brcm/nvram_ap6330.txt  /lib/firmware/brcm/brcmfmac4330-sdio.txt

 

in a shell on the target as root. Not sure where this Ubuntu  distribution fault has crept in.
nvram_ap6330.txt is actually the same file as android system:/etc/wifi/40183/nvram.txt and although not perfect, works better!

Share this post


Link to post
Share on other sites

image_32204.jpg.4b2196a6dcc7a31925db53502804fd11.jpg

 

I have come to a final conclusion! My Mecool M8S Pro (S912), Mecool M8S Pro W (S905W) and M8S Plus W (S905W) devices can only run kernel versions 3.14.29 (5.37 - 5.44). I started the first boot on the M8S Pro and tested the other models. Unfortunately, I was unable to use Wi-Fi on the my M8S Pro, with the Wi-Fi LTM8830 chip.

 

This chip is still not known by many, but the LTM8830 is a wireless LAN SDIO network interface device according to chipset maker Longsys. This module design is based on Qualcomm Atheros chipset QCA9377-3 is a single chip wireless network (WiFi) and Bluetooth, In other words, copy.


Recently I found a solution for bluetooth and wi-fi errors on devices with this chip. Who created the fix was the Magendanz of FreakTabs. Errors can be found in ATV builds based on the All in One Shiningworth Firmware. Well, it was easy to fix, but here I have no idea how to do. WiFi Fix for LTM8830.

 

Besides not reproducing the sound through the bluetooth headset, also was not able to play the sound through headphones connected to the AV input. Anyone interested in finding a solution to this I am willing to test, I would like to helper, but I do not understand anything about the development of distros.

Share this post


Link to post
Share on other sites
armbianmonitor -m doesn't check cpu temperatures anymore, it shows only cpu load and percentage?
 
Is there a working command to check cpu temperatures?
 

Anyone with the answer?

Share this post


Link to post
Share on other sites
18 hours ago, dbsharpe said:

On 150balbes 4.18.0-rc5 Ubuntu images, for those with T95 (p200) AML tvbox using meson-gxbb-p201.dtb / 200 device tree file, there is a problem with wifi caused by an error with nvram firmware files.
Problems manifests as wlan0 present but can't see any AP's.
To fix, use

 

mv /lib/firmware/brcm/brcmfmac4330-sdio.txt /lib/firmware/brcm/brcmfmac4330-sdio.txt.old
ln -s  /lib/firmware/brcm/nvram_ap6330.txt  /lib/firmware/brcm/brcmfmac4330-sdio.txt

 

in a shell on the target as root. Not sure where this Ubuntu  distribution fault has crept in.
nvram_ap6330.txt is actually the same file as android system:/etc/wifi/40183/nvram.txt and although not perfect, works better!

But RC5 is obselete now, is this fixed in the final version?

Share this post


Link to post
Share on other sites
6 hours ago, Reddwarf said:

But RC5 is obselete now, is this fixed in the final version?

Yeah its a Ubuntu thing, not kernel. The brcmfmac4330-sdio.txt issue is with images using kernels 4.9.40 upwards and I've also checked 4.18.0. Only ever used Ubuntu images and the problem is upstream somewhere with https://github.com/150balbes/pkg-aml/blob/firmware-aml-20180213/ .

Share this post


Link to post
Share on other sites

Hello @Balbes150, I wonder if you are interested in implementing support for the Wi-Fi / Bluetooth chip LTM8830. As I use the system through the Monitor (without audio box) I end up running out of sound.

 

But on the other hand I would like to know if I buy any WIFI and Bluetooth adapter, if they will work just like on the Windows computer or will it need some driver for generic devices?

Share this post


Link to post
Share on other sites

Just one more question ... Does my Mecool M8S Pro (Aml S912) come standard with a system built on Kernel 3.14.29, is there any chance that my Mecool M8S Pro will start the GUI with an image built on the Kernel 4.xx ? I made some tests, but just managed to run the UI with Kernel 3.14.29 images. I tested some with Kernel 4.18 but it did not start, it kept blinking some info at the moment it should start the GUI.

Share this post


Link to post
Share on other sites

Forgive me if my English sounds robotic or contains different words from everyday. I'm writing with a translator, I do not have English as a native language.

Share this post


Link to post
Share on other sites

I'm using at this time the v5.41 with the kernel 3.14.29 for my Mecool K1 pro. I would like to install media_build but I can't compile it because the headers are too old and/or I don't have the full kernel source.

The more recent versions don't include my device dtb and the default one (gxl_p230) makes the device unable to boot.

 

I think I have more or less the same question than Novato.

Share this post


Link to post
Share on other sites

Guys I'm trying to install ubuntu 18.04 server on Tanix TX3 mini but I don't have a usb keyboard to login, so right now I'm stuck in the login console, how do I login and connect to my wifi automatically on boot ?

Check out the screenshot below

IMG_20180830_161453.jpg

Share this post


Link to post
Share on other sites
5 hours ago, hillz said:

how do I login and connect to my wifi automatically on boot ?

connect via ethernet, find out the ip on your router - they usually have device list, connect from different machine via ssh and do what you want to do (first registration, wifi setup, etc)

Share this post


Link to post
Share on other sites

Hi,

 

I need some help by choosing the right dtb file. I bought a "MAGICSEE N4 TV Box" and I installed armbian on the micro sd card. I try to boot with it, but the system isn't starting. I can see the boot process, but I never come to the point, where I can write the Username + Password. I think its a problem with the dtb file. There are a lot of files, but I don't find the right one. Do you have any ideas?

 

 

Regards

Share this post


Link to post
Share on other sites
1 hour ago, Constantin Piffer said:

Hi,

 

I need some help by choosing the right dtb file. I bought a "MAGICSEE N4 TV Box" and I installed armbian on the micro sd card. I try to boot with it, but the system isn't starting. I can see the boot process, but I never come to the point, where I can write the Username + Password. I think its a problem with the dtb file. There are a lot of files, but I don't find the right one. Do you have any ideas?

 

 

Regards

Do you know anything else about this box? What cpu does it have? Do you know what board model it uses?

Share this post


Link to post
Share on other sites
15 minutes ago, Constantin Piffer said:

This one: "meson-gxbb-p200.dtb" ?

Yes you could try that, it should boot but wifi would probably not work

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
63 63